Snap Install changed Script install config location

What is the problem you are having with rclone?

I tried install RClone via SNAP, but encountered the problem related to permissions and editing the RClone config file. I took the advice of another forum post and removed the snap install and used the Script install instructions.

After it said
rclone v1.50.0 has successfully installed. Now run "rclone config" for setup. Check for more details.

I tried to run any rclone command and I get
bash: /snap/bin/rclone: No such file or directory

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Elementary OS 5.0 Juno (Built on Ubuntu 18.04 LTS)

Which cloud storage system are you using? (eg Google Drive)

Trying to use Google Drive

The command you were trying to run

rclone config

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

bash: /snap/bin/rclone: No such file or directory

It seems like the system is still mapping rclone to the install-location of where SNAP had put it. It doesn't look like it's the config location that is the problem, but rather the location of the actual executable.

I'm not great on Linux, but I am fairly sure that this is defined in some user-config - ie. where to go to find executables for various commands. This will likely have to be edited so that the path is correct to the current rclone install location.

It seems like the removal of SNAP got a little SNAFU'd because I'd expect it should be cleaning this up after itself under normal circumstances. (unless you just manually deleted stuff, in which case it would not be unexpected).

Exactly where to find this config is something you either have to google - or wait until a more advanced Linux user can come help.

Pretty sure it's related to this stuff:

And fixing it is probably not very hard for someone who knows the procedure (ie. not me hehe)

Normally what you need to do at this point is clear the bash hash cache with hash -r

NCW's advice worked. Learned something new :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.