Slow transfer speed on Windows Server 2016 vs Ubuntu 16.04

rclone v1.35-75-g381b845β
Amazon Cloud Drive

Identical hardware, both on hetzner, same files, same cloud.

Windows Single File:
D:\rclone\rclone.exe copy --checksum D:/TestW/ubuntu-16.04.1-desktop-amd64.iso AmazonUS1:/TestW/
Transferred: 41.812 MBytes (700.258 kBytes/s)
Errors: 0
Checks: 0
Transferred: 0
Elapsed time: 1m1.1s

  •          ubuntu-16.04.1-desktop-amd64.iso:  2% done, 717.297 kBytes/s, ETA: 33m20s

Windows Multiple Files:
D:\rclone\rclone.exe copy --checksum --transfers 42 “D:/TestM/” “AmazonUS1:/TestM/”
Transferred: 1.263 GBytes (21.138 MBytes/s)

Ubuntu Single File:
rclone copy --checksum /tmp/ubuntu-16.04.1-desktop-amd64.iso AmazonUS1:/TestU/
Transferred: 1.265 GBytes (21.184 MBytes/s)

I saw the same behaver on OVH as well. And also the same on US and UK accounts. Its okay if you transfer many files, then you can just up the transfer number to max out the connection. But if your transfer a really large single file it takes forever.

How many times did you repeat the experiment?

I’ve seen lots of variability copying large single files to ACD.

I would say:
8 weeks running on OVH, 2 virtual servers (Hyper-V), 1 win 2016, 1 ubuntu.
4 weeks running on Hetzner, 2 physical servers, 1 win 2016, 1 ubuntu.
The results has always been consistent: Each transfer on win 2016 is limited to 600-700KB never over, Ubuntu always full speed.

Just did a test on my work computer 100/100mb with Windows 10 1607:

rclone.exe copy --checksum C:/Users/anjoh2/Downloads/ubuntu-16.04.1-desktop-amd64.iso amazon1:/TestWORK/
2017/02/11 17:52:49 amazon drive root ‘TestWORK’: Waiting for checks to finish
2017/02/11 17:52:49 amazon drive root ‘TestWORK’: Waiting for transfers to finish
2017/02/11 17:53:48
Transferred: 236.875 MBytes (3.786 MBytes/s)
Errors: 0
Checks: 0
Transferred: 0
Elapsed time: 1m2.5s

  •          ubuntu-16.04.1-desktop-amd64.iso: 16% done, 5.956 MBytes/s, ETA: 3m22s

So it does look like its limited to the 2016 server.

I’ll retry on monday with a clean virtual win 2016 on my work computer to compare.

I have to say I haven’t tried rclone on 2016 server.

When it is running could you see how much CPU it is using? Just wondering if the crypto acceleration isn’t working for some reason.

Maybe the aes instructions aren’t visible for some reason.

I usually run it thru Crypt, but all the tests above is without, just to be sure that wasnt the issue. As I wrote above I’ll set up a few VMs on monday to test some more. I could give you a copy afterwards if needed for some more troubleshooting? Any prefered hypervisors?

I’d be interested in the results.

I can get my own Windows 2016 VM from work if necessary - that will keep Microsoft happy anyway!

I’ve run rclone on Windows 2016 Server and I have gotten 80 MB/s and up. I did have high cpu on my system until I changed motherboards and cpus then it really isn’t even a blip on my speed. I suspect that there was something on the old motherboard/cpu that used cpu for disk transfers but it also could have been the slow CPU speed.

I just ran a test using 10 transfers. CPU Usage was around 20%
12.007 MBytes/s, ETA: 1m18s
11.113 MBytes/s, ETA: 1m32s
18.829 MBytes/s, ETA: 1m49s
6.892 MBytes/s, ETA: 1m14s
11.315 MBytes/s, ETA: 1m37s
6.449 MBytes/s, ETA: 38s
12.660 MBytes/s, ETA: 24s
27.549 MBytes/s, ETA: 1m50s
14.184 MBytes/s, ETA: 17s
12.289 MBytes/s, ETA: 1m17s

So it looks like to me that it’s running pretty well though maybe there is something my cpu supports that the crypt is using that the OP doesn’t have.

rclone: Version “v1.35-75-g381b845β”

I have used noticed the slow transfer speed in windows server but never worked on ubuntu. After searching a lot for its solution I found that GS Richcopy 360 is good in solving such problems. Its multi threaded file transfer feature helps in transferring files at lightning speed. Although its paid but affordable and it saves your precious time, time is money according to me. I hope this comment helps! Thanks.