Slow rclone cache read speeds

In an effort to get around a couple of google drive bans I’ve had lately I started looking at using cache. With default options in a Gdrive -> Cache -> Crypt setup I’ve found read speeds to be 7-8x slower than just using Gdrive -> Crypt. The speeds are on file downloads, not streams - I’ve seen these go from basically full speed of the NIC (100mb/s) to around 15mb/s with cache. I’m using rclone mount and accessing it with nginx (web server). The files seem to start fast (at full speed) but then slow to a crawl after about 20 seconds.

Is anyone able to point me in the direction of why this might be the case?

I started with defaults but have played with the following flags:

–buffer-size 200M
–cache-chunk-size 8m
–cache-workers 10

None of those seemed to make any difference.


It might be worth trying with --buffer-size 0 to see if that helps.

Feel a bit silly but thought I was running latest version with 1.40. I have updated to 1.41, disabled the buffer and it all seems much better. Cheers!

1 Like