Slow and unstable OneDrive upload speed

I'm trying to upload massive amount of data into OneDrive. I have 1Gbps uplink on Hetzner dedicated server, but no matter what I do I can't fully utilize 1Gbps upload speed. Of course I'm using my own API keys.

I'v tried --transfers flag with 8, 12, 16 even 32 but the upload speed never goes beyond 600 Mbps and it's very unstable. Sometimes its 100 Mbps, next second it's 400 Mbps. Very very unstable.

I also used --onedrive-chunk-size=250M (OneDrive supports max 250M)

At first I thought, maybe Hetzner have issue with Microsoft; but then I tried DigitalOcean, Vultr, Linode and a Russian server. All of them had 1 Gbps uplink but the results were same.

Clearly Microsoft throttling upload speed, right?

The only thing left for me is to try Azure, but I don't wanna. Because their bandwidth pricing is horrible.

I would agree with you. I'm amazed you got it working so well actually! Onedrive has always seems a bit slow to me.

Does it have to go into Azure? B2 is cheaper as is Wasabi...

Haha. You misunderstood. What I meant to say was try to upload to OneDrive from Azure Virtual Machines. Since both are from Microsoft there is tiny chance the upload speed won't be capped. This is just assumption. But the problem is they charge for egress, even if they go into OneDrive (unlike Google).

Need to transfer 400 TB, so I guess I've to settle with the current speed. :confused:
Seriously Microsoft is the worst.

Ah, I see.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.