sizeDiffers incorrect after transfer

I try to remove --rc-files ,always 500 internal error

I try to remove --rc-files ,always 500 internal error
Test on vmware ubuntu ,get this
image

webUI version 2.04

CMD

#!/bin/sh

curPath=$(dirname $(readlink -f "$0"))
HomePath="$(dirname "$curPath")"
cd $HomePath

echo $HomePath
pid=ps -ef|grep rclone|grep -v grep|awk '{print $2}'
if [ ! -z "$pid" ]; then
kill -9 $pid >/dev/null 2>&1
echo "kill exist rclone PID $pid"
fi
nohup $HomePath/rclone/rclone rcd --rc-addr=":5572" --ignore-case --ignore-case-sync --progress --log-file=$HomePath/log/rcloneRunning-$(date +'%Y%m%d').log --log-level DEBUG --rc-user=abc --rc-pass=abc --rc-allow-origin=":5572" --rc-web-gui --rc-web-gui-no-open-browser --rc-files=$HomePath/webgui --rc-job-expire-duration=10s --rc-job-expire-interval=1s :local,no_check_updated: &

Dir tree

image

May be there are same reason with windows 500 internal error.
Am I using it right ?
I want no check local update ,and not effect remote

Possibly!

Did you try the latest beta? I fixed a bug with Windows path handling? the latest beta

window get sam error
image

I have test latest master code,same error too.

Let me rearrange and organize my questions and the attempts I have made.

Problem

I use RC mode and synchronous file commands, using asynchronous, no: local, no_check_updated:.
The first step is to synchronize files normally;
The second step is to modify the source or target file, repeat the first step.
The target file will be deleted.

Try and Test

I debugged the source code and found that the reason for the deletion was that the sizeDiffers judgement error led to the deletion of the file
I used the flag --local-no-check-updated
Follow your suggestions and use :local,no_check_updated: as the startup parameter.
sizeDiffers and other APIs work correctly, but webUI cannot be opened.

WebUI Test

I went to debug the webUI related code and found that Flag could not be resolved :local,no_check_updated:


This unresolved parameter is used as the startup parameter of RCD
Replaced rcflags.Opt.Files, causing the webUI interface to fail to find the correct path.
Which leads to a 500 internal error.

Am I using it correctly: local, no_check_updated:?

This should work used as a parameter to rclone rcd --local-no-check-updated

If you want to use :local,no_check_updated: then you put that into the gui or use it via the rc

rclone rc operations/sync fs=:local,no_check_updated:/tmp ....

Does that make sense?

You can also put it in your config file

[local]
no_check_updated = true