SIGINFO ignored by --daemon on macOS

What is the problem you are having with rclone?

Rclone ignores SIGINFO on macOS when ran as --daemon

I'm passing --daemon --stats-one-line --stats-log-level NOTICE --log-file <path> and then send SIGINFO via kill -s SIGINFO <pid> but nothing is emitted in the log.

From a brief review of a source it appears that the signal handler is only installed when rclone is ran interactively, not as a daemon.

Is SIGINFO in --daemon mode ignored on purpose, or is it an oversight of implemetaiton?

The use case is to be able to monitor the progress of upload by rclone daemon, without filling up the disk with periodic --stat logging, instead requesting progress on-demand only when needed via the signal.

If there is alternative way to accomplish that -- please point me to the right direction!

What is your rclone version (output from rclone version)

rclone v1.56.2
- os/version: darwin 12.0.1 (64 bit)
- os/kernel: 21.1.0 (x86_64)
- os/type: darwin
- os/arch: amd64
- go/version: go1.16.8
- go/linking: dynamic
- go/tags: cmount

Which OS you are using and how many bits (eg Windows 7, 64 bit)

macOS 12, Intel x64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount google-drive: /Users/alex/google-drive \
--volname "Google Drive" \
--log-file /Users/alex/Library/Logs/Mounter/google-drive.log \
--drive-acknowledge-abuse \
--vfs-cache-mode full --vfs-cache-max-size 1024G --vfs-cache-max-age 1000h \
--vfs-cache-poll-interval 5m --attr-timeout 60s --dir-cache-time 1000h \
--poll-interval 0 --daemon-timeout 599s --daemon \
--stats-one-line --stats-log-level NOTICE

The rclone config contents with secrets removed.

type = drive
root_folder_id = ...
client_id = ...
client_secret = ...
scope = drive
token = ...

A log from the command with the -vv flag

<There is nothing logged when kill -s SIGINGO is issued -- which is the essence of this topic>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.