Sharing OneDrive mounted drive with Samba


I have "successfully" mounted a OneDrive folder using rclone, more specific /home/wedge/OneDrive (ubuntu).

But it's acting in a strange way if I use the ls command to go inside that directory there is no problem and I can see the content previously loaded to the OneDrive shares, but if I use Midnight Commander to navigate the OneDrive folder doesn't appear as a folder, it appears like a file in red and showing "?OneDrive" and I can't get inside.

I shared that folder using Samba, some devices say the folder is empty and others like the mac return a message error.

Any idea what the problem is?

Rclone Version 1.51.0

I used the following command to mount the OneDrive account to the folder:

rclone --vfs-cache-mode writes mount onedrive: ~/OneDrive &

And the following options for sharing the folder using samba:


comment = Ubuntu File Server Share
path = /home/wedge/OneDrive
browsable = yes
guest = no
read only = no
create mask = 0755

Most likely, you need to add in allow other to your mount command:

 --allow-other                            Allow access to other users.

Thanks for the fast response.

Where should I put the —allow-other string in the command? I have tried in all the positions and I always get an error warning.

How would be the complete command look like?

I normally do my mounts like this and I would change the & to --daemon.

rclone  mount onedrive: ~/OneDrive --vfs-cache-mode writes --allow-other --daemon

You'd want t make sure sure in /etc/fuse.conf, it has allow_other uncommented as well:

felix@gemini:~$ cat /etc/fuse.conf
# /etc/fuse.conf - Configuration file for Filesystem in Userspace (FUSE)

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#mount_max = 1000

# Allow non-root users to specify the allow_other or allow_root mount options.

Thank you, working flawlessly.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.