Sharing Mounted Google Driver over LAN in Windows 10

Hello, i have setup one crypt rclone google drive mount as windows service and know i'm able to acess my encripted files over LAN using iOS App "Documents" /"nplayer" or another computer with STFP LAN acess.
Ocorrs that somefiles/folders still inacessible even after setting up rclone.exe as SYSTEM USER using it as one windows service...
It gives me permisson erros like "Failed opening remote file" (nplayer app) or "failed to find directory folder" (Documents app).
It only happens with a few folders/files (like 1/4 of the total directories) and those erros did not ocorrs when acessing it via another windows computer.
Has anyone been through the same? know how to solve this?


so on your windows computer, you have a rclone mount/
and other devices on your lan can see that rclone mount?

for your rclone mount, you should use a log file with debug info.

what version of rclone?
what version of winfsp?

first, I mount the encrypted rclone as a driver letter, then i share it over the LAN using SFTP... Doing that i'm able to see the mounted crypted drive letter using other devices, like mobile/iOS.
rclone is version rclone-v1.51.0-095-g6fdd7149-beta-windows-amd64
winfsp is the lastest version v1.7B1/ WinFsp 2020.1 B1

how are you sharing the mount over SFTP?
rclone server sftp?

and which files are cuasing the error?
do you get the same every on each device, other then the windows computer.

do you have a log with debug info?

I don't know if rclone as a SFTP server too instead a client... I'm sharing it using CerberusFTP server... So I mount it to one drive letter and the sftp software server can find the rclone mounted drive/folder/files if i run rclone.exe as SYSTEM/windows service.

The problem is that some folders i can not acess it, the log file that i receive is :

2020/04/15 13:31:02 [5] Unable to access local directory 'J:\BACK\2020 jan\newyear ' : The system cannot find the file specified.

"2020/04/15 13:31:02 [5] Unable to open directory handle to '/G.Dr/BACK/2020 jan/newyear"

this is the logs that shows in the SFTP server

In iOS app the error code is like the same, as i already said, it gives me permisson erros like "Failed opening remote file" (nplayer app) or "failed to find directory folder" (Documents app).

so the first log is from rclone
and the second log is from sftp server?

what is your rclone mount command?

you could try rclone server ftp and see if you get the same errors.

Yes, the first is from rclone (drive is mounted in J:)
the second log is from sftp

my mount command:

mount gcrypt: J: --allow-other --dir-cache-time=160h --cache-chunk-size=10M --cache-info-age=168h --cache-workers=10 --attr-timeout=1s --vfs-read-chunk-size=128M --vfs-cache-max-age=1h --vfs-cache-mode writes --buffer-size=128M --rc --config "C:\rclone3\rclone.conf"

alright, let me try the rclone ftp server

Tried with rclone, but got one similar error ....

2020/04/15 15:24:53 [14] Stat failed for ... The requested file does not exist.

I think this is an error with the system file names, like unrecognizable characters, for example i have sucess acessing another folder after renaming it for a short name, so it was: "december pictures " (note the space after "S" in the last name pictureS; now it is just "december pictures" without the space after "s" in the last name ..
After doing that everything worked again and now i'm able to access the folder.
In the end, i think i have found what is causing the directory / folder not found problem as i changed the folder name and it has become accessible ... There is any way to change rclone file system name? like utf-8?
or something that will enable folders to be accessible even with special names like spaces after the last name?

It might be that the SFTP server can't cope with trailing spaces in the names. I know rclone's SFTP server and client can both cope with trailing spaces as that is part of the integration tests.

Rclone uses UTF-8 for all file names everywhere.

hi, sir, thanks for answering me! I tried with rclone using the command:

c:\rclone3\rclone.exe serve ftp gcrypt: --user romano --pass test001 --addr

Then i have acessed the ftp server using iOS Documents and it gives me permission error when trying to reach those folders that have special names....

is possible to use --umask 000 in windows 10? i'm trying to use this command but i got an unknown flag error

Error: unknown flag: --umask
  rclone mount remote:path /path/to/mountpoint [flags]

Can you describe in what way the names are special?

No, windows doesn't use Unix permissions.

hi! thanks for your attetion and help with my problem...
When i say special names, i mean folder names that contains the following characters:

"ã" "õ" "$" "_" "(blank spaces)" "!" "#" "&" "ç" "á,à,â" "º" "*" "()"

I can't have acess to those folders, it keep giving me permission errors or not found folder/path/directory problems...
Even when the directory exist (cause i have no problem to acess it with the windows system/administrador account) in the FTP or SFTP mounted acess using iOS i receive a message error saying: the directory don't exist.

In short, this is my situation:

First, i can acess to all those special name folders if i use the rclone mount command;

mount gcrypt: J: --allow-other --dir-cache-time=160h --cache-chunk-size=10M --cache-info-age=168h --cache-workers=10 --attr-timeout=1s --vfs-read-chunk-size=128M --vfs-cache-max-age=1h --vfs-cache-mode writes --buffer-size=128M --rc --config "C:\rclone3\rclone.conf"

Secondly, i can not acess those folders when mounted with the command above and sharing the drive letter throught FTP or SFTP. For example, i got the "directory not found error" when i use the FTP or SFTP acess with Documents iOS app...

This ocorrs even when i use this another command (rclone serve) and acess the drive via the FTP connection.

"c:\rclone3\rclone.exe serve ftp gcrypt: --user romano --pass test001 --addr"

In addition to running rclone as a windows service, there is any way to set permissions like permission to "everyone" when using it with Windows OS?

yes, if you do a command such as mount gcrypt: J:

Just to confirm, you can see those folders with the mount command.

Did you try a different FTP or SFTP program? Maybe it is a problem with the Documents IOS app?

Ok that makes sense.

Rclone itself works fine with those file name characters - it uses UTF-8 throughout. I think SFTP will work fine with any UTF-8 characters - not sure about FTP. FTP can be funny about spaces and punctuation, so I suggest you test with SFTP.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.