Sharepoint configuration

Hi all,
i'm using Rclone to synchronize a Google Drive : it works like a charm !
But, i'm having having problems with another account : a sharepoint site shared with one of our subcontractors.

What is the problem you are having with rclone?

I'm testing the onedrive configuration.
When i'm trying to register a new app ( on Microsoft_AAD_RegisteredApps at azure portal ) it tells me : ERROR 403 (Accès refusé ; Vous n'avez pas accès ; Vous n'êtes pas autorisé à enregistrer les applications dans l'annuaire ... Pour demander l'accès, contactez votre administrateur).

Our subcontractor has his own sharepoint, and has defined an access to us on it.
We are sharing documents on it.
Url is like : sharepoint com / sites / <OUR_COMPANY> / Shared%20Documents

I have no problem to access it from windows. But i need to schedule a sync job from a linux server.

Is Microsoft OneDrive configuration the good way to access to our sharepoint or not ?

Many thanks for your help


What is your rclone version (output from rclone version)

rclone v1.46

Which OS you are using and how many bits (eg Windows 7, 64 bit)

RedHat 6.10 (Santiago)

Which cloud storage system are you using? (eg Google Drive)

Microsoft OneDrive (maybe this is a mistake)

v1.46 is over two years old.

please update to latest stable v1.55.0 and test again.

you're right.
I've just updated rclone to : rclone v1.55.0.

So, i've tried the same oneDrive configuration : but i still can't register my app on ApplicationsListBlade (at portal azure website).

Moreover, i've tried to connect my sharepoint with a webdav configuration.
With a such config, i've this error :
$ rclone ls Sharepoint:/
2021/04/11 18:39:27 ERROR : : error listing: couldn't list files: 403 FORBIDDEN: 403 FORBIDDEN
2021/04/11 18:39:27 Failed to ls with 2 errors: last error was: couldn't list files: 403 FORBIDDEN: 403 FORBIDDEN

My config is :
type = webdav
url = OTHER-COMPANY DOT sharepoint DOT com / sites / MY-COMPANY / Documents
vendor = sharepoint-ntlm
user = user AT MY-COMPANY DOT fr
pass = *** ENCRYPTED ***

In fact i need to access to the "Shared Documents" folder. Is it possible ?

Thanks for your help.


yeah, nothing like an update.

403 are usally permission issues.

for the first time, i setup a sharepoint, no problem

3 / Sharepoint site name or URL (e.g. mysite or
   \ "url"

and used

i did not try webdav, i used onedrive

Hi asdffdsa,
do you have configure an app on : portal . azure . com / #blade / Microsoft_AAD_RegisteredApps / ApplicationsListBlade page to get your Client ID ?
When i'm trying to add any, i've an error 403.
I think that my account does not have any sufficient rights.
Many thanks

i have an office365 account. that comes with a sharepoint.

i think you are creating a sharepoint server at
perhaps try

4 / Type in SiteID
   \ "siteid"

or perhaps this helps
Adding Sharepoint SiteID

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.