SharePoint and Office formats - xls etc

I’m trying to use rclone (1.46) to migrate files from a QNAP/linux NAS to a SharePoint online store. I’m using WebDav as per the documentation.

It works just fine with most file formats. e.g. PDF is just fine. But it fails with the MS Office file formats. e.g. xls fails to transfer.

The error I get is below:
2019/03/01 14:18:24 ERROR : somewhere/file.xlsx: corrupted on transfer: sizes differ 106768 vs 113176

I think the problem is that SharePoint adds something to each MS Office file which inflates the file size. So the size comparison will always fail. I’ve had the same issue using other Windows based synching tools.

I have tried disabling various checks in rclone. But no such luck. The folder tree copies with lots of files. Just no MS Office formats. And that’s most of what I have.

Is there any other switches to ignore the comparison after copying? Seems a fantastic solution if I can just get past this…


The switch you want is :

  --ignore-size              Ignore size when skipping use mod-time or checksum.

Hopefully that will work!

Same problem here (while mounting the share with rclone mount). --ignore-size helps only so far, that now I get a
failed: corrupted on transfer: QuickXorHash hash differ
I tried adding --no-checksum, but still the above error when copying a .docx file.

Note, this only happens when both the file extension and the file contents are .docx or .xlsx. Other file contents with .docx extension or an office file with another extension (like renaming it to .zip) does not trigger the error...

  --ignore-checksum    Skip post copy check of checksums.

is the flag you want. This should really be fixed in the onedrive backend.

Can you check to see if there is an existing issue and if not please make a new issue on github?