Shared resource over HTTP

Good day guys!

I am looking for a solution in which I can share a drive (encrypted) over the internet. My idea was to be able to mount the shared drive via rclone on the remote side. Any ideas?

Many thanks!

Check out here:


i run nginx over a rclone mount. Works great with the DAVS modules enabled.

1 Like

Very innovative! Some time ago I prototyped an rclone serve http command which I haven’t got round to releasing.

Hi Guys

Thanks for the replies. Just one thing I cant seem to grasp is how do I make a rclone share of say /media/share to be able to share this via rhttpserve?

Ideally I want to make a new share “/media/share” called “share” and then make this encrypted with encrypt called “shareCrypt”. This crypted share I then want to share over HTTP via rhttpserve.

Many thanks and great work with rclone!

the rclone serve http command will share it just fine but you’d have to compile it yourself. I did use it on my android phone a while ago and it streamed/worked okay. Since this isn’t released, you’re going to be better of doing this differently. One way if you want something REALLY REALLY simple is to just use python to create a http server on a normal rclone mount.

python -m SimpleHTTPServer

I doubt it will stream but will let you get your data for download. It isn’t secure… but if that fits your usecase, it is a KISS approach. nginx would be far more robust but more complicated.

rhttpserve is also an option but you should probably contact that developer.

I decided I’d better rescue that branch before it bitrots away so I’ve merged it to master along with some tests. Invoke it with rclone serve http remote:, see rclone serve http --help also!

Finid it here! (uploaded in 15-30 mins)

1 Like

Great stuff Nick!

Will give it a shot this weekend, thanks man.


I just fixed a timeout bug and disabled Range for the moment… (uploaded in 15-30 mins)

Thanks again Nick. Just got round to installing it now.
Unfortunately I get this error message: Error: unknown command “serve” for “rclone”.

Any ideas?

My mistake, sorry. Will give it another shot.

No worries. You might want to use the latest beta since I fixed some more stuff!

Cool, can try that next. I have now done a test setup (within LAN).Trying to watch a movie via the server.

Server side:
2017/10/26 22:38:48 ERROR : d1/Movies/3 Days to Kill (2014).mkv: Failed to write file: write tcp> write: broken pipe

Client side:
2017/10/26 22:39:46 ERROR : d1/Movies/3 Days to Kill (2014).mkv: ReadFileHandle.Read error: low level retry 6/10: Open failed: HTTP Error 416: 416 Requested Range Not Satisfiable

This is most likely what you wrote in the docs: Range header is not supported yet

I have also tried to make a crypt share and serve that, but got an error in browser: Directory not found. Is it even possible to serve a crypted share?

Thanks a bunch Nick!


Yes - no range will cause that.

That should work - it did when I tried it…

I’ve implemented Range now, see (uploaded in 15-30 mins)

This took a bit longer than anticipated as I ended up doing a massive refactor of rclone code. The result is that I made serve webdav too and I’ve got a solild platform for the future!


Your the man Nick! :grin: Can’t wait to give it a shot!

is it possible to add password to protect this webdav?
and https?

Hi Nick, sorry for the delay. Just wanted to give you a heads up for this added feature! Works great. Would really be perfect if there would be a way to add some security as explained by gunum_gunum.