SFTP remote to local copy - "Failed to copy: file does not exist"

Hello friends.

I'm attempting to transfer files from a remote SFTP server to my local HDD and I keep getting the error "Failed to copy: file does not exist."

I have a little programming experience with Go and I first attempted to transfer the files programmatically. I tried many different things to get it to work - specifically using client.OpenFile() with various flags instead of the typical client.Open() function, since the client.Open() function always gives a "file does not exist error." I received other types of errors using OpenFile. When I tried client.OpenFile(srcFile, 0700) I got an "EOF" error. When I tried client.OpenFile(os.O_WRONLY|os.O_CREATE|os.O_TRUNC) I received a "read from 13 for 32768 from 32785 not supported. (SSH_FX_FAILURE)" error.

Since RClone uses Go, I thought I would try the same operation with RClone and see if it works. I get the "Failed to copy: file does not exist" when I attempt with RClone.

Here's my rclone.conf file:
type = sftp
host = {removed}
user = {removed}
port = 22
pass = {removed}
md5sum_command = none
sha1sum_command = none

Thank you for looking into this!


Can you do an rclone lsf -R sftpremote: and check that works?

Can you also check the case of the command line you are using. I'm wondering if you are using the exact case in the directory?

Try using rclone cat sftpremote:dir/file.xml using the path from the rclone lsf does that work?

What sftp server is it - do you know? It identifies itself as "SSH-2.0-SFTP server" which is a bit generic!

Do you know if the the files are links/junction points?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.