Several folders are shown with rclone tree but not synced in Google drive

What is the problem you are having with rclone?

I have configured rclone with Google drive and things initially looked good. However when syncing Google drive to a local folder, several folders are not downloaded. What is more strange is that I can see those folders when I use rclone tree command.

For example, rclone tree shows

folder 1
   file 1
folder 2
   file 2
   file 3
folder 3
   file 4
   file 5

But then when using rclone sync, folder 2 and folder 3 are not downloaded.

Edit 1:
I did try different things. One thing I noticed is that doing rclone tree gdrive: with and and without --drive-shared-with-me gives a completely different structure of the files. I expected adding --drive-shared-with-me would keep the structure of the folders, but have additional files and folder which are those that have been shared with me. For example, rclone tree gdrive: --drive-shared-with-me does not show folder2 and folder 3.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 20.04

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone sync gdrive: ~/gdrive/ --drive-shared-with-me --drive-alternate-export --progres

The rclone config contents with secrets removed.

type = drive
scope = drive.readonly

A log from the command with the -vv flag

I get an error that the --vv flag is not valid.

hello and welcome to the forum,

as per the documentation
use -vv, not --vv

as per the documentation; that is the expected behavior.
"Only show files that are shared with me"

Thanks. I see. I thought --drive-shared-with-me adds shared with me files.

So to get both my own files and shared with me, I have to run the command twice?

i would say you would have to run the command twice.


I believe it would need to be run twice or could create a union of the two I think. :thinking:

Any thoughts on how to do a union?

I was thinking you'd just use:

and merge the regular and shared into one. I've not tried it nor do I really use shared-with-me much but logically I think it would work.

Thanks. I couldn't figure out how to use union with and without --drive-shared-with-me options. I think I will just run the command twice. Please let me know if you come across an example using union with different options.

You can create two remotes for your drive and add this:

shared_with_me = true

into one of them. Then you can combine those two remotes with a union remote. If you use rclone config in the advanced settings it will walk you through setting that as well.


Interesting! Thanks.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.