Settings for on Windows (can be then used with Plex server)

Over the last day or so I have read up and got my Rclone mount working nicely with Premiumize cloud storage in Windows . You can then if you like point your Plex server at it to play your files in your Premiumize cloud.

As I said this is totally new to me using Rclone and cmd etc. But I thought this info may help others to get a little bit on the right track (as well as remind me how to do it again when I need to!) I couldn't find any step by step instructions from scratch for someone like me who hasn't used Rclone before.

Download Rclone and also Winsfp for your PC

Open a cmd window and type rclone config

Select new Give it a name I called mine remote.

Type premiumizeme

Follow instructions, select the defaults. It will open browser to pm website to accept rclone link.

Then to use it I type (remember remote is what I called mine, and I am giving it P as a drive).

rclone mount remote: p:

Then it starts, you have to leave the cmd window open all the time. You can then find the drive P in your windows to view your files.

Right that is the basic way to get it working. Next I will paste the argument to get it working even better so it has a cache on the pc, I had to do this to get the big remux files working properly for me.

To stop it hold Ctrl C

rclone mount remote: p: --config "C:\Users\ryana.config\rclone\rclone.conf" --dir-cache-time 1m0s --poll-interval 15s --cache-dir=C:\Users\ryana.config\rclone\CacheDir --vfs-cache-mode full --vfs-cache-max-size 200G --vfs-cache-max-age 2h --vfs-read-chunk-size 512M --vfs-read-chunk-size-limit off --vfs-read-ahead 512M

You would change the dir= to your own folder location for the cache files. and obviously the mount part at the start.

also I bumped the chunk and read values up to 512M which I think seems excessive compared to most things I read have it at 128M - but I think this value helped me being larger. Will see how it goes. I have 900Mbps download speed.

From there, it should work fine, you have to leave that cmd window open all the time on your server to have rclone working. This next step is optional but I think quite good,
Open up Windows Task Scheduler, and create a new task, follow the wizard, tell it to open cmd.exe and then paste your argument below it.
I set mine to start on startup, so it auto starts if I reboot PC

I had to make sure when typing the argument part in scheduler that I wrote the following

mount remote: p: --config "C:\Users\ryana.config\rclone\rclone.conf" --dir-cache-time 1m0s --poll-interval 15s --cache-dir=C:\Users\ryana.config\rclone\CacheDir --vfs-cache-mode full --vfs-cache-max-size 200G --vfs-cache-max-age 2h --vfs-read-chunk-size 512M --vfs-read-chunk-size-limit off --vfs-read-ahead 512M

Basically typing the path for the conf. file before you add all the arguments you want.

Remembering my premiumize rclone is called remote and my drive letter is p.

Hope this helps anyone, as I say I'm not experienced with this sort of thing so excuse any errors or things I shouldn't have done. I found it hard trying to find all the info and have it spelled out to me, so this should get you on the right track.

If you have any suggestions for improvements, Im all ears! Cheers

Here is some info I found on the argument values which you can alter to suit your system

--cache-dir= is the location it will write the cache files as it uses them, these are temporary files that will clear out on their own, no management is necessary.

--vfs-cache-max-size is the maximum amount of disk space VFS caching is allowed to use, I have a 500G disk I allocate 200G to.

--vfs-cache-max-age is the life of the files that are allowed to remain in the cache directory, they will clear out after 168 hours, you can set this to as long or short as you need.

--vfs-read-chunk-size is the size in which each chunk will download, I find 128M to be sufficient, reduce if these are too large for your internet speed.

--vfs-read-chunk-size-limit is how many chunks are allowed to build up for each individual file, leave this off because if you don't you wont be able to properly seek backwards if you wanted to re-watch something.

--vfs-read-ahead will allow rclone to read 128M ahead and store in memory before writing to the cache location, it's a pre-buffer, keep this size the same as the --vfs-read-chunk-size for best results.

thanks for the guide.

--allow-other does nothing on windows...

Awesome, thanks, will edit that out

another tweak would be to use windows task scheduler over nssm.

  • a nice gui
  • can start a task at boot time
  • built into windows

Cool, will look into that as well, thanks!

the downside of nssm, as per that guide.

  • using regedit to to edit hard coded parameters
  • forced to run nssm as system user
  • no way to run a task on a schedule
    i find it much more flexible to create/tweak/test a .bat/.cmd batch file using a nice text editor and test on the command line.
    then when that batch file is optimized for your use case, then create a task with task scheduler to run the batch file.

Will have a bit of a test now to see how it goes, thanks

You are correct, easy to use Task Scheduler, cheers

cheers and beers...

might change the title of the post to
Settings for and Plex server on Windows

1 Like

Nicely written. Thank you for sharing!

1 Like

Hey thanks for the guide. I seem to run into an issue when mounting. After rclone mount remote: p: the commandline shows everything is all good but there is no such mounted drive in my windows directories.

hello and welcome to the forum,

i should be able to help you, as that i a common problem.

please start a new post and answer the questions in the template.

I appreciate the offer to help. I was successfully able to mount it just not as a drive. Whenever I tried to mount as a separate drive rclone would run but show no new drive. Mounting it in the existing drive worked however as long as I wasn't in the root directory. Is there a reason I should figure this out versus just using the current configuration?

since you have not posted that, i have no idea.

since you have not posted that command with a debug log, i have no idea.

so far, you have not provided any actionable info, if you had started a new post, there would have been a template of questions.

I'm saying I got it to work using this command:
rclone mount remote: C:\rclone\mount
rather than...
rclone mount remote: p:

Mounting to a drive (for example p:) rclone would run but not actually mount the drive. Mounting rclone within my C:\ drive as long as it isn't the root directory (thus C:\rclone\mount) did work.

I chose not to start a new post because this seemed relevant to the existing post as when I followed the instructions listed above I ran into this issue but was able to find this solution. Why take that to a completely different thread?

Also you mentioned being unable to mount a virtual drive is a common issue, maybe my google-foo is weak but I wasn't able to find any hint of a solution to the problem other than what I came up with. I am happy to troubleshoot that in its own thread though I just don't have my PC in front of me.

No need to get sassy here, its been less than 12 hours since my original reply and I am currently at work. I haven't really had the time and either way the point seems moot because I got it to work. I was just curious if mounting a virtual drive a few folders deep was bad practice?

that was not my intention. did not know you were at work.
i was just asking for the command that was not working with a debug log.

as for being a common issue on windows; so far, i have helped more than 15+ fellow rcloners with that exact issue.

Like I said before I appreciate the help. I'll look into making a new post this weekend. I probably wont have time today, except maybe late tonight.

Mind linking some of those posts? Maybe it would be good to make a post that links to all of those as a kind of master thread for the issue? That way when this comes up again you can simply drop a link for people capable of troubleshooting on their own to a degree. I haven't been able to pull any of them up in my searches for some reason, probably using the wrong keywords.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.