Settings advice for Samsung Smart TV Plex client

Just wondering if I could get some advice on my setup as I can’t watch anything on Plex without it buffering

Some details below

Remote: Google Drive with own API key
Plex Server: Late 2012 iMac w/ Core i5, 8GB RAM, 1TB SSD, MacOS Mojave
Internet: 240Mbps
Client: Plex app on Samsung Smart TV

I opted to use a VFS setup, see mount script below:

/usr/local/bin/rclone mount Deanicus:Plex /Users/deanicus/Gdrive --log-file /Users/deanicus/Downloads/Rclone/rclone_mount.log -vv --allow-other --dir-cache-time 96h --drive-chunk-size 64M --timeout 1h --umask 002 --buffer-size 1G --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit 2G

I took the advice from this thread: New Feature: vfs-read-chunk-size and set the client to Direct Streaming rather than Direct Play but I can’t go more than 5 minutes without buffering

I am handling uploads separately from the mount so only really care about read performance

Any advice appreciated. Thanks!

What are you trying to stream? You have a debug log to post?

Could be a Samsung issue as well if you search for that, you’ll see lots of complaints.

Some clients tend to open/close a lot and by the nature of a cloud mount, it doesn’t work well. If you can post a debug log “-vv” of your playback and the issue, it’s very easy to see in the log.

I mainly watch 720p files of TV shows and occasionally 1080p movies, definitely no 4k

Just copied this out of the log as an example

Edit: can I attach it instead?

Need the full log and you would have to reproduce the problem. You can attach it, dropbox/pastebin/anything you want.

Right, I’ll mount and create a new log file. Give me a few moments

So I killed the existing mount, remounted under the same settings but with the below log.

I then tried to play a 720p file on the TV and it stopped after about a minute and eventually got a network error

Hopefully this helps

From the rclone side, that log looks without any issue.

It opens the file and doesn’t close/open it repeatedly and seems to read through without much of a problem. The reads go in order and seems to be go on without any issues.

If you turned off Direct Play, that means Plex is using the transcode settings to keep a buffer. I’d look outside of rclone and check Plex/client and ensure that all is good there.

There is nothing in the rclone log to indicate any issues unfortunately from the rclone side.

Apologies for the delay in responding.

Thanks for going through that, it definitely appears to be the client as I am not seeing the same issues playing on my phone or through the web client

I’m going to try a chromecast next

As for the server, the logs I can see in the console section of the web client do not show many errors. Mostly they are complaining about not being able to parse a device schema for something on my network (not the TV as the IP is different).

Do you think switching to the cache backend would show any improvement or perhaps even caching the VFS?

If so, do you have any recommended settings for those?

Thanks again!

I doubt cache would have any effect as that log looks okay.

Ah ok

Issue seems to be the client. The app is an Orca one for a 2014 Samsung TV. Last update was Aug 2018 but in the thread on the Plex forums, Orca himself said he would no longer be updating it

I am going to move to a Chromecast instead. My tests so far look good

Thanks for your help guys

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.