Server side copy between 2 google drives

#1

Can someone please explain to me the steps or command which can be used to server side copy between 2 google drive.
Basically I want to upload using my bandwidth to one drive and then copy the new files to my backup drive without having to reupload it myself.
I think there is a way to do this by sharing the folders or something but I couldnt find what exactly needs to be done.
(Both drives have the exact same content just the main drive has some newer files which the backup drive does not and those are the ones I want to server side copy to the backup drive)

#2

If you share the folder to the other gdrive and then “add to library” you can connect just to that one and sync from folder to folder. It’s pretty slow though tbh.

Rclone sync remote1:sharedfolder remote1:destfolder

Personally I’d just spin up a Google compute micro and sync it there between the two remotes.

#3

If you use rclone v1.47 you should find you can server side copy between two different drives.

2 Likes
#4

Can you tell what command/ flags to use with the copy command ?

#5

@calisro listed it above on the commands.

#6

I am getting api error with that command.

#7

Can you share what you ran and the -vv log of what the output is?

#8

D:\rclone>rclone sync gdrive2:“18dbci6jo0cllqpufj7q782hv9qrthlrcrc9h9m96mef1airfk4g” gdrive2:“Plex\n16jl3a037eph65dj69iv9m2dg\18dbci6jo0cllqpufj7q782hv9qrthlrcrc9h9m96mef1airfk4g” -vv

https://pastebin.com/ea4fzhmL

This is the output of running the command for a few seconds and then manually stopping it with control+c

#9

Make sure to create your own client ID/API key if you haven’t already:

https://rclone.org/drive/#making-your-own-client-id

That looks like the command worked fine though minus a few retries in there.

#10

I have created my own client id and api key. And the command works successfully for the subtitle files (very small in size less than 1 MB) but does not work for any video file which are around 500-900 MB

#11

I don’t see any errors in the log related to that.

Can you provide a log that has that in it?

#12

Wont also do a server side copy between to remotes?

#13

I ran the command for a different folder and it worked, and then it worked for this folder aswell :smiley: thanks !

#14

I am not sure what you are trying to say.

#15

Ok. Great. If you get an issue, just capture the command with the -vv output and we can review it.

#16

Since update rclone to the latest version 1.47 copy or sync between gdrive always result with googleapi error 404 files not found. Folders is create to the destination drive but not the files inside those folder. Test this under both windows 10 and ubuntu. Fall back to the previous version 1.46 with the same command rclone copy g1: g2: work without error above.

#17

If you’d like to make a new thread, post your version and logs on the issue with -vv so we don’t hijack this thread as it’s solved for now.

Thanks!

closed #18