Selfupdate doesn't seem to respect the --quiet option

What is the problem you are having with rclone?

rclone selfupdate --quiet is not quite quiet :slight_smile:

What is your rclone version (output from rclone version)``

rclone v1.56.0
- os/version: ubuntu 18.04 (64 bit)
- os/kernel: 5.3.0-7648-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.16.5
- go/linking: static
- go/tags: none

Which OS you are using and how many bits (eg Windows 7, 64 bit)

POP_OS 18.04 (Ubuntu 18.04 based)

/etc/os-release

NAME="Pop!_OS"
VERSION="18.04 LTS"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Pop!_OS 18.04 LTS"
VERSION_ID="18.04"
HOME_URL="https://system76.com/pop"
SUPPORT_URL="http://support.system76.com"
BUG_REPORT_URL="https://github.com/pop-os/pop/issues"
PRIVACY_POLICY_URL="https://system76.com/privacy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

Which cloud storage system are you using? (eg Google Drive)

N/A

The command you were trying to run (eg rclone copy /tmp remote:tmp)

sudo rclone selfupdate --package deb --quiet

The rclone config contents with secrets removed.

N/A

A log from the command with the -vv flag

N/A (the problem is the -q flag which is mutually exclusive with -v

Log from the command with the -q flag

rclone is up to date

I expected it to be completely silent at least when there's nothing to do. In fact, I think it even should be silent when it does update without any problems (exit codes might be different if it had nothing to do and when it had to update and did it successfully)

What did it print?

I suspect that it is outputing things to stdout directly rather than using the logging system.

If you'd like us to fix this then please open a new issue on Github.

1 Like

"rclone is up to date"

Yes. It's here, but I'm too rusty at programming and never wrote a line of go :slight_smile:

All right. I was doing that when I read that I had to post here first :slight_smile:

Here it is: self update's --quiet option, not quite quiet ยท Issue #5505 ยท rclone/rclone ยท GitHub