Seeking back is buffering

What is the problem you are having with rclone?

I'm using jellyfin and when I play a movie/tv shows it loads quickly, even when i seek forward it was instant but when I seek backward it loads for like 3-5 seconds (sometimes longer). Is there something wrong with my mount options? I have 24gb ram and that's why i use 1gb buffer-size.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.1

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-1016-oracle (aarch64)
  • os/type: linux
  • os/arch: arm64
  • go/version: go1.18.5
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Team Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount gdrive-meliodas-crypt: /media/gdrive --config=/home/ubuntu/.config/rclone/rclone.conf --allow-other --dir-cache-time 10m --poll-interval 5m --log-file /home/ubuntu/rclone/logs/meliodas.log --umask 002 --cache-dir=/home/ubuntu/rclone/cache --vfs-cache-mode full --vfs-cache-max-size 100G --vfs-cache-max-age 720h --vfs-read-ahead 2G --buffer-size 1G --tpslimit 10 --tpslimit-burst 10 --drive-use-trash=false -vv

The rclone config contents with secrets removed.

[gdrive]
type = drive
scope = drive
token = *****
team_drive = *****
root_folder_id =

[gdrive-crypt]
type = crypt
remote = gdrive:crypt
password = *****
password2 = *****

A log from the command with the -vv flag

Logs is too long. Sorry. Here is the dropbox link https://www.dropbox.com/s/tv2ghdjdd7funcr/logs.txt

Top part of the log is missing so I can't validate/see the mount options or version.

Some of the options you have are not great.

I'd remove buffer-size, read-ahead as that really does do much.

You are slowing down yourself with tps liimits of 10/10 so I'd remove them.

The file you are playing is all local as well and playing from the cache:

grep present logs.txt

Gives an idea as present true is there for every item. If the cache disk is slow, perhaps that's an issue as you are basically reading from local disk at this point.

i remove the buffer, read ahead and the tps and it was better than before. i just notice that when i play a video, jellyfin buffer it forward. but when i skip it backward it remove the buffer video.

t

btw, any reason you use tps 12 on your github repo? im using google workspace team drive, is it okay to remove them?

thank you

I don't use Google Drive anymore and Dropbox has smaller TPS limits as that's the sweet spot for Dropbox.

Google's API has much more API per second and rclone has generally some good defaults.

I don't use Jellyfin so I am unsure on that as Plex has no issues moving around it's a local file with the debug log you shared so should work like any local file at that point.

thanks for the info about tps limit. what is the best way to capture logs when playing a video, i tried it and rclone logs too fast.

You can specify a log file location:

# Log file location
--log-file /opt/rclone/logs/rclone-tv.log

i did but when i play a video it generates hundreds of lines within second using -vv on my mount. anyway to limit it?

It's based on the log level you set. Generally, I don't run in debug. I only turn on debug to troubleshoot an issue.