Samba folder not accessible

What is the problem you are having with rclone?

Samba folder not acessible from windows or other network client. So I have read some solution provided in anterior versions of rclone, such as adding the --umask 000 or the --attr-timeout 1ns , with no sucess. If I dont mount the folder with rclone, it can be acessed from network easily... What should i do differently? Regards

What is your rclone version (output from rclone version)

rclone v1.52.2

  • os/arch: linux/arm
  • go version: go1.14.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Raspi OS Buster 32Bits

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

 rclone --vfs-cache-mode writes mount dropbox: ~/dropbox  --attr-timeout 1ns --umask 000

The rclone config contents with secrets removed.

type = dropbox
token = {"access_token":..(removed some fields of token)}

A log from the command with the -vv flag

2020/07/22 22:56:10 DEBUG : rclone: Version "v1.52.2" starting with parameters ["rclone" "-vv"]
  rclone [flags]
  rclone [command]

Try adding --allow-other to your mount options. Since Samba probably runs as another user than your mount, it does not have access to the mounted drive.

Not 100% sure, but I think that's what's going on.

1 Like

Hello, Thank you. It worked just fine.... :slight_smile:

Before it started to work, I had to go to sudo nano /etc/fuse.conf and enable
user_allow_other and then it worked just fine :slight_smile:
This flag is not part of any described in Is there any other family of flags?

this can be a little confusing.
if you read the documentation for
"This describes the global flags available to every rclone command"

--allow-other is specific to the mount command.

--allow-other                            Allow access to other users.
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.