S3 permissions for rclone copy command

With rclone v1.51.0, I am able to use the rclone copy command to put files into a S3 bucket with an AWS IAM Role that has restricted permissions. With rclone v1.52.0, I receive an “AccessDenied” (HTTP 403) error. The AWS permissions that I have are similar to what rclone documents here: https://rclone.org/s3/#s3-permissions.

With both version of rclone, I see debug output that is similar to: Rclone with brand new AWS account for S3. The AccessDenied error is the response from a “PUT / HTTP/1.1” request, which is a CreateBucket S3 API call. Unfortunately, I do not have that AWS permission in some environments. rclone v1.51.0 seems to move on with copying the file despite the AccessDenied error. rclone v1.52.0, on the other hand, fails the copy command.

Bug or by design? Work-around?

you need to post

  • your command, best if you try to copy a single file, so the debug logs will be small.
  • debug log using v1.51.0
  • debug log using v1.52.0

I think this may be fixed in 1.52.2

Can you give that a go?

Works when I use 1.52.2! Sorry...I should have tried the latest release before posting. I have actually been using 1.52.0 for a while, but never noticed this issue because I have been transferring directories. Just yesterday, though, I tried a single file and saw this issue. Thanks for the help!

No worries! It was a regression which got fixed in the point release:-)