S3 Access Using Windows 10

What is the problem you are having with rclone?

I am unable to access S3 using Windows 10.

Version

rclone v1.55.0
- os/type: windows
- os/arch: amd64
- go/version: go1.16.2
- go/linking: dynamic
- go/tags: cmount

OS
Windows 10, 64 bit

Storage System

AWS S3

The Command

rclone ls --no-check-certificate AWS:my-bucket 10:13:00 Failed to create file system for "AWS:my-bucket": LoadCustomCABundleError: unable to load custom CA bundle, HTTPClient's transport unsupported typecaused by: unsupported transport, *fshttp.Transport

The error happens whether I tell it to load certs or not. My AWS CLI config works fine, same with boto3.

The rclone config contents with secrets removed

[AWS]
type = s3
provider = AWS
env_auth = false
access_key_id = ***
secret_access_key = ***
region = us-gov-west-1
location_constraint = us-gov-west-1
acl = private

A log from the command with the -vv flag

rclone ls -vv --no-check-certificate AI-Factory:ai-factory-dldev
2021/04/14 07:27:31 DEBUG : Using config file from "rclone\\rclone.conf"
2021/04/14 07:27:31 DEBUG : rclone: Version "v1.55.0" starting with parameters ["rclone" "ls" "-vv" "--no-check-certificate" "AWS:my-bucket"]
2021/04/14 07:27:31 DEBUG : Creating backend with remote "AWS:my-bucket"
2021/04/14 07:27:31 Failed to create file system for "AWS:my-bucket": LoadCustomCABundleError: unable to load custom CA bundle, HTTPClient's transport unsupported type
caused by: unsupported transport, *fshttp.Transport

Is it the same case as this?

Do you have environment variable AWS_CA_BUNDLE set?

Thank you! That did the trick!