Running rclone with wine: solution

This is not exactly a howto guide, but more of a howto workaround this "wine + rclone" issue.

There was a topic with the same name open several months ago, but it was auto-closed. I believe I have the solution here.

If you are running rclone for Windows on a Linux environment through Wine and receiving an error such as this:

--log-systemd not supported on windows platform```

Try adding the following to the Wine environment:


Setting this environment variable tells rclone to use a logging file and not the system's logging facility, and for me, at least, it allowed rclone for windows to run under wine as it ignored the Linux logging facilities. Depending on how you are running wine, you may need to set the EV in a variety of ways.

To Note: I would still argue this is an rclone bug, as rclone, due to being a wonderful piece of cross environment software, is looking for ways of auto-detecting appropriate default options for each environment. This results in rclone noticing(somehow) that this is actually running Linux, and in turn, it expects the logging facility to be there, and is automatically enabling the flag that supports this logging facility. However, it should likely be also checking the build variables, and noticing it's not built for Linux at that time, and not checking for or trying to enable any flags that aren't appropriate for this OS. This is a default behavior that is setting the flag, not the user, and in this case, the default flag that rclone is setting for itself, is invalid.

Likely easy to fix this in rclone, but even easier to workaround, and I would say it's better to do a larger revamp and have all OS specific flags that get set by defaulting behavior, also take in to account target build environment before auto-setting those flags.

Why wouldn't you just run the proper binary on the proper system? Why put it through WINE?

1 Like