Rlone mount issues


#1

Hello everyone. Complete noob here. I’m having some issues mounting ACD with rclone on my unraid server.

I started by watching This Video But was not able to get anything working.

So I SSH’d into the server as root and I’m trying to mount it manually. I’m currently testing with a non-encrypted remote, just to make it easier on me. But with all my testing I think I have broken something :sob:

When I try to mount a remote I get a mount error.

After some reading I figured there was an issue from trying to mount remotes in the past. So I checked the mounts and tried to remove the old one (I tried but I might have the command wrong)

As I can only upload 1 image I tried to get it all on one screen.

Any help would be greatly appreciated.


#2

Hi there,

i would just restart the server.
If the mount command gives you an error, always check with
mount
if it isnt mounted anyway and check if the rclone process isnt running with:
ps aux |grep rclone

So when you rebooted and anything is fine again, check first the endpoint (/mnt/disks/amazon) is existing:
ls /mnt/disks/

then mount it with (provided the folder on ACD is called open):
rclone mount amazon:open /mnt/disks/amazon &

It should work. If you want to add options later, just unmount it with:
fusermount -u /mnt/disks/amazon
and then mount it again with the desired options.

If you have more problems, please always state your versions etc. with:
rclone --version
uname -r
etc…
Hope it works now for you.

Just one more thing: You are sure you want to do all this as root?
Have a nice day


#3

You sir are my hero. I got it working!

Did a few tests and everything looks good. The last hurdle I have to jump is mapping 2 diferent folder locations for Plex.

One for TV and one for Movies. Would I just do 2 mounts for the folders?

rclone mount amazon:TV /mnt/disks/amazon/TV &
and
rclone mount amazon:Movies /mnt/disks/amazon/Movies &

Thanks again for your help!


#4

That is what I do for multiple mounts. I just do one for each in Screen. But I do it a bit differently since I point at the folder that contains my movies and tv folders. Say a Media folder.

But I do use simultaneous mounts. But one goes to Amazon and one goes to Google. Both have the same content. I have plex look at both since plex can look at two folders in the same library. It will only list a movie once but it will ask what version to use when you play something. So people can pick one and if it has problems they can choose the other one.


#5

So I got it all working. The only problem now is that the mount disconnects after some time.

Is there a mount command I can use to keep it mounted? Or is this more of a cron job?


#6

After how many time your mount is disconnected ? On mine it never been disconnected but i restart my VPS quite often .

Have you got logs on the moment it disconnect ?


#7

I’m not sure how long it takes for the mount to drop. And I cant find it in a log file.

I setup a user script on the server to remount every hour. But now I have a bunch of duplicate mounts.


#8

If you want to know what happens you should try to redirect the mount log to a file like

rclone mount remote: /folders/XXX/ >> /var/log/mountRclone.log 2>&1 &

So you can see what happen. Can you try that and give the log ?

Mine never dropped at the moment and its run for > 72H since last reboot so the log may explain your problem


#9

So after you mounted your drive “rclone mount remote:path/to/files /path/to/local/mount” you did nothing else to keep it mounted after you rebooted?


#10

i add the same command in a script launch on startup