Retrieving Files with --max-age

What is the problem you are having with rclone?

Trying to retrieve files that are less than 5 days old

What is your rclone version (output from rclone version)

rclone v1.54.0-beta.4848.e00bf3d72

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd -vv "gdrive:Plex Cloud Sync\Movies" --max-age 2021-09-01
and tried
rclone lsd -vv "gdrive:Plex Cloud Sync\Movies" --max-age 5d

The rclone config contents with secrets removed.

type = drive

A log from the command with the -vv flag

2021/09/06 09:54:31 DEBUG : --max-age 5.579533358195602d to 2021-08-31 20:00:00 -0400 EDT m=-482071.553152399
2021/09/06 09:54:31 DEBUG : rclone: Version "v1.54.0-beta.4848.e00bf3d72" starting with parameters ["rclone" "lsd" "-vv" "gdrive:Plex Cloud Sync\\Movies" "--max-age" "2021-09-01"]
2021/09/06 09:54:31 DEBUG : Using config file from "C:\\Users\\barbera\\.rclone.conf"
2021/09/06 09:54:31 DEBUG : Creating backend with remote "gdrive:Plex Cloud Sync\\Movies"

You seem to be using some odd beta version.

Grab the latest stable.

Can you share a rclone lsl of a file you'd expect to match?

 rclone lsl GD:hosts
      206 2021-09-03 09:36:53.946000000 hosts

I grabbed the latest version and re-ran the commands and still returned the same thing. I ran your command with one of the recent files that should've popped up:

5111808252 2021-09-03 00:12:52.000000000 Ted Bundy American Boogeyman (2021).mkv

Your command is the problem as you doing rclone lsd which only lists directories.

felix@gemini:~/test$ ls -al
total 8
drwxrwxr-x  2 felix felix 4096 Sep  6 11:07 .
drwxr-xr-x 15 felix felix 4096 Sep  6 11:07 ..
-rw-rw-r--  1 felix felix    0 Sep  3 00:12 testfile
felix@gemini:~/test$ rclone ls /home/felix/test --max-age 5d
        0 testfile
felix@gemini:~/test$ rclone lsl /home/felix/test
        0 2021-09-03 00:12:12.000000000 testfile

So what would be the right command to run to gather items that have been added in the last X amount of days?

The one I have above would work fine with just rclone ls

so the ls worked with the max age. I did check some of the files and noticed they have a weird modifed date. I guess I'll need to see how I can fix those files.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.