Resume B2 upload?

What is the problem you are having with rclone?

I want to upload large files to Backblaze B2 (100-800GB) with rclone.
I didn't even manage to upload the smaller ones (100GB) yet because rclone gets stuck or my connection resets sometimes.

Is there a way to resume B2 uploads?
I know that the files are uploaded in smaller chunks, but if I start my rclone command it starts from zero.

I know that Cyberduck can resume, but it doesn't support parallel uploads and is very slow.

What is your rclone version (output from rclone version)

rclone v1.49.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Win 10 Pro 64 bit

Which cloud storage system are you using? (eg Google Drive)

Backblaze B2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy ./xxxxxxx-00-00.mrimg backblazeb2:xxxBucket/BackupC/ -P --transfers 32 --b2-disable-checksum

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)


I think there a few issues / bugs with the B2 upload of big files if you search on the forums and the latest beta I think fixed it.

If you can share a log file as noted with the -vv, it would confirm that.

@Animosity022 is right there was an issue with this, and it is fixed in the point release 1.49.3 which I just released, so @rcloner001 I suggest you give that a go.

Hi @ncw,

it's still not working. No resuming:

> rclone copy ./AXXXXXXC-00-00.mrimg backblazeb2:KxxxxxU/SxxxxC/ -P --transfers 1 --b2-disable-checksum
Transferred:       18.060G / 140.170 GBytes, 13%, 3.305 MBytes/s, ETA 10h30m30s
Errors:                 0
Checks:                 0 / 0, -
Transferred:            0 / 1, 0%
Elapsed time:  1h33m14.9s
 *                  AXXXXXXC-00-00.mrimg: 12% /140.170G, 3.355M/s, 10h21m9s


> rclone copy ./AXXXXXXC-00-00.mrimg backblazeb2:KxxxxxU/SxxxC/ -P --transfers 1 --b2-disable-checksum
Transferred:      200.211M / 140.170 GBytes, 0%, 3.058 MBytes/s, ETA 13h1m8s
Errors:                 0
Checks:                 0 / 0, -
Transferred:            0 / 1, 0%
Elapsed time:      1m5.4s
 *                  AXXXXXXC-00-00.mrimg:  0% /140.170G, 2.933M/s, 13h34m21s


> rclone version
rclone v1.49.3
- os/arch: windows/amd64
- go version: go1.12.3

You can't quit rclone and have it resume... It should pick up transfers that get interrupted but only if you don't quit it.

Would be a nice feature though. I use my laptop and sometimes I have to shut it down and carry it with me to school.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.