ResilioSync had no permission to write in mounted Google Drive


#1

https://github.com/ncw/rclone/issues/2564

What is the problem you are having with rclone?

ResilioSync had no permission to write in mounted Google Drive

What is your rclone version (eg output from rclone -V)

rclone v1.43.1

  • os/arch: linux/amd64
  • go version: go1.11

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux rclone 4.9.0-8-amd64 #1 SMP Debian 4.9.110-3+deb9u4 (2018-08-21) x86_64 GNU/Linux

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount rsyncgdrive:rsyncgdrive /root/rsyncgdrive --copy-links --no-gzip-encoding --no-check-certificate --allow-other --allow-non-empty --umask 000

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

docker run -d --name ResilioSync \ -p 8888:8888 -p 55555:55555 \ -v /root/resiliosync:/mnt/sync \ --restart always \ resilio/sync


#2

What’s the actual log or error message you are seeing?


#3

There is a good chance that --vfs-cache-mode writes will fix this.