Rename files in remote

Hi there

I have again a very silly question. Is it possible to rename files with rclone in remote? I guess, it should be possible with rclone mv, however, I have tried:

./rclone move gdrive:/rcc/oldname.mp3 gdrive:/rcc/newname.mp3, and the error is the following:

Google drive root ‘rcc/newname.mp3’: can’t move files on overlapping remotes.

How do I correctly rename files? Thanks for your help!

Currently it isn’t possible! rclone can rename directories, but not files.

However for the next release I plan to make some commands which will: https://github.com/ncw/rclone/issues/476

Would that be for 1.35?

Would a rename work on crypt? I don’t see why not but just wondering. I have an encrypted file on Amazon and Google. It’s the same file but with different names. I want to rename one so the names are the same and the data is mirrored but I can’t. It’s a large file so I don’t want to delete it and reupload. Until the ability is added I could manually rename it if I could somehow narrow down which file it is.

I kind of wish there was some tool where I could input the plain text name of a file and it would give me the encrypted filename so I can more easily locate it manually on the share if need be.

Should do yes.

If you use the latest beta you can use the moveto command which will let you rename a file. It should work on Drive and ACD without downloading and re-uploading the file even with crypt…

so

rclone moveto secret:oldname secret:newname

I don’t know why I didn’t think of this question as well. If I have an encrypted mount, can’t I just rename it that way through the OS? I don’t really ever interact with the mounts as I just use them to view and verify the files.

That might work… That bit of the rclone mount system is more experimental that the other bits!

A bit old, but today I just tried a workaround and it worked.
Mounted my crypted acd without --read-only, used filebot (modifying with finder or explorer might do as well) to rename a movie and boom the file got renamed, I unmounted, mounted again and re-scanned Plex library and it’s still working :blush:

As long as you dont rename folders directly on mount its ok, if you rename folder the whole content will deleted. ( this is quite huge bug that should be fixed asap )