Recently rclone mount problems. IO wait and terrible slow speed

Hi everyone.
I encontered the problem with the rclone mount. It was working for no problem at all for years and recently I noticed problem with IO delay and also there are problems with download from rclone mount and also sometimes download speed gets only 100kb/s while the IO reaches 90%.

My setup.
rclone mounted under linux machine, Debian 11. I got this problem when direct downloading from the linux machine over winscp and also same situation when accessing the files over the samba share under windows (samba share from linux machine).

rclone mount gdrive: /mnt/gdrive --allow-non-empty --allow-other --ignore-checksum --vfs-cache-mode full --cache-dir /mnt/rclone_cache --vfs-cache-max-age 24h --vfs-cache-max-size 30G 

There was no problem before and transfer downloading large file from rclone mount was around 40MB/s. Right now there is problem accessing the files. Randomly (not often) I can download with a reasonable speed and also upload but sometimes getting the file list over rclone mount is problematic. FIle size which cause the problem is from 100MB to few GB - exact the same problem.

Was there any update on that module or are there any steps I can try?
Any suggestions would be great.

hello and welcome to the forum,

when you posted, there was a template of basic questions for you to answer.
help us to help you and provide all the answers.

@asdffdsa I am sorry for missing that.

I hope this template pasted here will he ok

What is the problem you are having with rclone?

Problem with slow transfer from rclone mount reaching 100kb/s. Only now and again I got reasonable transfers 30+MB/s
Randomly, even listing the content of the rclone mount gives timeout. IO wait time reach up to 90%

Run the command 'rclone version' and share the full output of the command.

rclone v1.53.3-DEV

  • os/arch: linux/amd64
  • go version: go1.15.9

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount gdrive: /mnt/gdrive --allow-non-empty --allow-other --ignore-checksum --vfs-cache-mode full --cache-dir /mnt/rclone_cache --vfs-cache-max-age 24h --vfs-cache-max-size 30G 

After checking the version of rclone, I updated it to the 1.61.1

no worries.

i have re-posted this from the template

 **STOP and  READ**: 
Do not type in "Latest".
Do not just type in a version number. Run the command and share the full output.
Are you on the latest version of rclone? You can validate by checking the version listed here:

so please update rclone to latest stable, v1.61.1 and test again

Updated to the 1.61.1
Rebooted the system and when checking performance unfortunatelly is the same problem

Above photo when tried to download the file 900MB from rclone mount. Download speed on 170kb/s

rclone v1.61.1

  • os/version: debian 11.6 (64 bit)
  • os/kernel: 5.15.85-1-pve (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

imho, does not seem like a rclone problem,
as this is a new issue on your machine, persists using that old version and the latest version.

we do have linux experts who can help but keep in mind,
we cannot see into your computer, that is why we ask you to answer all the basic questions in the help and support template.

Sure, I will gather some logs and will get as much I can regarding this problem.
Thank you so much for your help sofar

Right, this is possible case. Just to note I have no IO delays like that in overall performance of rest of the system/services I run. System is stored on mirrored ssd. Will get all what needed and will come back to with it.

Did some testing and the problem might be in a system configuration and not rclone mount itself. the mount is fine and I can download the large files from mounted rclone sorce with full speed but over winscp. When I samba share mounted rclone folder, than all fun starts with the very high IO and very slow speed.

I need to investigate the samba configuration itself first.

Anyway, I am very greatfull for your replies.
Thanks a lot. If I will get solution to my problem I will get back to inform about it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.