Rebalance Union Google Drive with random create

What is the problem you are having with rclone?

I had a google shared drive and exceeded the maximum number or objects. I then created two more shared drives and joined them into a union using the random create action. This works well and the mount can continue, however every time it lands on the full shared drive, the upload fails.

Is there a way to evenly balance existing data across 3 different remotes? Or should I move ahead with my plan to just do a move from the full remote to another and stop it after a few hours hoping that catches about half of it.

What is your rclone version (output from rclone version)

1.56.0 amd64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)



If I understand you correctly, then you are using the “rand” (or “eprand”) policy on a union backend and it sounds like you would like to use “lno”, "lus" or “mfs” policy instead.

You can see all the possibilities here:

If I am mistaken, then it would be nice to see the redacted config of the involved remotes and a log with -vv showing the error you get when copying a single file with rclone copy.

I've tried lno, but Google drive doesn't support number of objects from my experience and other posts in this forum. Has that changed in newer versions of rclone?

I don't know if Google Drive supports "lno".

I would make a little test if I were in your situation - and choose one of the other options if it isn't supported.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.