Realized I wasn't using own gsuite api after getting Error 403: User Rate Limit Exceeded


I've been using rclone for about 5 months and until now I had never got an userRateLimitExceeded, I use gsuite, I have a unencrypted root rclone called "maxsuite" and an encrypted rclone called "maxsuitecrypto", all of my files are uploaded into the crypto drive and the only folder that there is in the unencrypted is the crypted one.
I've been scanning my music library (for RuneAudio), my plex library and uploading some music (I think this was the problem because I set --checkers to 100 to make it faster, I didn't know about the limit). So after getting this userRateLimitExceeded I checked the suggested page and realized my api had 0 hits, even the graphic of the last 30 days show no hits at all. All this time wasn't I using my own gsuite api? I could have sworn that I had set it up when I started using rclone, I followed a guide to do so.
Then I realized that in the upper-left corner there's a dropdown to select the project, and only the unused, unencrypted project shows up (maxsuite) which is the one I don't use to upload and that the encrypted one (maxsuitecrypto) is not showing. Am I not using my own gsuite api for my encrypted drive? if so, how can I set it up? Please help!
the userRateLimitExceeded seems to be gone now after I added --fast-list to the sync command, not sure if that was the reason or that it went away because time passed.
I'm a bit lost about my api and projects, need some help to set it up properly once and for all.
Sorry for the long text, thanks!

What is your rclone version (output from rclone version)

rclone v1.53.1

  • os/arch: windows/amd64
  • go version: go1.15

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Win10 64bit

Which cloud storage system are you using? (eg Google Drive)

Google drive, Gsuite Enterprise

The rclone config contents with secrets removed.

type = drive
scope = drive
client_id = ****
client_secret = ****
token = {"access_token":"****","token_type":"Bearer","refresh_token":"1//03-_****","expiry":"2020-10-25T11:57:06.2030595+01:00"}
root_folder_id = ****

type = crypt
remote = maxsuite:/backup
filename_encryption = standard
directory_name_encryption = true
password = ****
password2 = ****

You can use:

Best to leave things defaults if you as 100 checkers would create quote a lot of problems as Google only allows about 10 API hits per second. Defaults are your friend.

thanks for replying!
Yes, I won't set --checkers as high again. My doubt now is if my crypto drive is using my own api key. In the rclone.conf file I have the remote line pointing back to maxsuite and my maxsuite account has already its own gsuite api token:

type = crypt
remote = maxsuite:/backup

what am i doint wrong for my transfers to the crypt drive are not appearing as hits to the api key? is there anything wrong in my conf file to be so? or what is causing it?

nothing is shown to be uploaded/downloaded to my gsuite account in the last 30 days and obviously I have, a lot, I'm uploading as of right now

Did you authorize again?

I haven't changed anything since the day I've set it up and tbh have totally forgotten how was the process. I see in the Google Drive API page that the api is enabled, but I'm not sure if that applies only for the unencrypted maxsuite or also for the encrypted maxsuitecrypto, in the upper drop-down I only see maxsuite. Should I reauthorize it? how? I've noticed that the rclone config file has this line in the encrypted drive remote = maxsuite:/backup could the :/be the problem? is not usual to write / after :

You need to authorize it after you make the changes to the changes to the client ID and secret.

what changes are you referring to? I haven't changed anything. just yesterday got a userRateLimitExceeded for setting --checkers too high. Today userRateLimitExceeded seems to be gone, I'm uploading things to the encrypted drive right now, so it's working. But yesterday when I went to check about the limitation I realized that the api wasn't showing any hits, even when I'm using it today and have been using it the whole month. But I haven't done any change in the api, the password or the rclone.conf file. Just modified a sync command. I haven't ever deauthorized the api and I wouldn't know how to authorize it again.

If you setup a client id and secret, you need to authorize it for rclone to actually use it.

rclone authorize is the command.

If you aren't seeing hits in the API console, you need to authorize it.
If you aren't seeing the client iD /secret in your rclone.conf, you need to re-run the config and add it.

Based on your first post, it's there so you need to authorize it.

ok, I've authorized it with rclone authorize drive and allow rclone api in my account, now in cmd I see: `Paste the following into your remote machine --->
{"access_token":"***" where should I add this? in rclone.conf? manually? and only in the unecnrypted drive right?

sorry, it also says this: "token_type":"Bearer","refresh_token":"****","expiry":"2020-10-25T15:38:01.9941474+01:00"}

In the spot in your rclone.conf that has the same line:

ok done that, I had to also run rclone.exe config reconnect maxsuite:otherwise it wouldn't let me sync. Now I'm syncing again, but I still can't see hits to the api, here:

or here:"duration":("groupValue":"PT1H"))

You'd just need to make sure the right client ID and secret are in the rclone.conf and authorize/reconnect and that's it.

If you can post the steps you did and screenshots, that would be great.

1 Like

I'm uploading files using the current rclone.conf now, so they should be all right, could you please point out in which page can I see the api's client id and secret to crosscheck them against the ones I have in conf? if they differ I simply rewrite them manually with a text editor in rclone.conf and authorize/reconnect?
I have no idea the steps I followed the first time I set it up because it was around 5 months ago, that's why I'm so lost, I thought all this time I was using my own api key, but seems like I wasn't

In the Credentials area:

I must've messed up things the day I set it up, because I see two oAuth 2.0 Client ID created the same day (dec 14. 2019, I thought it was more recent). I tried copying the first id and secret to .conf file and reauthorize/reconnect but still seeing no activity in panel control :frowning: I'll try the second one

it worked with the second one!!! I can't believe I wasn't using the api all this time, should I remove the other one?

I like things clean so I'd remove it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.