ReadFileHandle.Read error: Failed to authenticate decrypted block - bad password?

I was testing Plex with a decrypted vault last night and my stream kept pausing. This morning when I looked at the terminal in OS X, I am seeing the error below. Not only for this file but several others which I didn’t even try to play. Any ideas?

2016/10/19 21:54:36 Vault/Movies/test.avi: ReadFileHandle.Read error: failed to authenticate decrypted block - bad password?

Here is the issue about this:

I haven’t figured out what is going on yet…

Excellent. Thank you.

I am still getting this on the beta from yesterday or the day before on MAC 10.11.6

ReadFileHandle.Read error: failed to authenticate decrypted block - bad password?

Can you capture a log of it happening with -v --dump-headers --debug-fuse --log-file log-file.txt please?

You can either post that somewhere or email it to me directly at and I’ll take a look.

I shall. I also just got this:

ReadFileHandle.Read error: read tcp> read: operation timed out

That is some sort of Internet timeout which rclone can’t do anything about unfortunately :frowning:

I figured that part was internet related. I emailed the log.

I can’t find it anywhere (I get a lot of email!) Can you email it again to and put “rclone logs from aneuploid” in the subject please?

Just sent the log again.

Thanks - got it this time (had to rescue it out my spam box for some unknown reason!)

The only strange thing in the log is that your media player opens and closes the file a couple of times before reading from it. I don’t know why though…

Apparently rclone managed to read about 150MB of data from the file before it got the ‘bad password’ error.

Can you try downloading the file that gave the error file with rclone (not with fuse) to see if it downloads correctly? So something like

rclone copy -v "Encrypted:Mxxxxx/Bxxx xxxxxx"  /tmp

And make sure it downloads correctly. That will help me work out whether this is a fuse problem or not.

Interesting. When I try to copy the file from Amazon, it returns this

-bash: syntax error near unexpected token `)’

I’ve seen this from other Plex logs in other threads. I think it is just the way plex processes them… and it delays open times for those users unfortunately.

The file itself does have () as most of my files do include the year of the movie in parenthesis at the end of the file before the extension. This is standard naming convention for Plex.

" Movie (2002).mkv"

I renamed the file without the (2002) at the end and uploaded it to ACD and I am still getting the bad password error. I then was able to download the file from ACD to my desktop and it plays fine.

OK there is definitely a bug in rclone mount. Someone else opened an issue here: which I think is the same as yours @aneuploid

I haven’t got to the bottom of it yet!

Also I’m concerned there is a problem if you do lots of activity with rclone mount that there is something it isn’t releasing properly - to see this run with the --debug-fuse flag and look at all the messages like this you get when you shut it down with fusermount.

 2016/11/15 15:55:43 fuse: <- Forget [ID=0xf358 Node=0xfa Uid=0 Gid=0 Pid=0] 1
2016/11/15 15:55:43 fuse: -> [ID=0xf358] Forget
2016/11/15 15:55:43 fuse: <- Forget [ID=0xf345 Node=0x10d Uid=0 Gid=0 Pid=0] 2
2016/11/15 15:55:43 fuse: -> [ID=0xf345] Forget
2016/11/15 15:55:43 fuse: <- Forget [ID=0xf35b Node=0xf7 Uid=0 Gid=0 Pid=0] 2
2016/11/15 15:55:43 fuse: -> [ID=0xf35b] Forget
2016/11/15 15:55:43 fuse: <- Forget [ID=0xf35c Node=0xf6 Uid=0 Gid=0 Pid=0] 3
2016/11/15 15:55:43 fuse: -> [ID=0xf35c] Forget

I believe I have worked out what is going here…

Can you try this beta please - it should return an “unexpected EOF” error instead of the “failed to authenticate block” error.

While on its own this isn’t very significant, it will allow me to retry the connection which will fix this issue properly. So if you could have a go with this beta and let me know what happens. (uploaded in 15-30 mins)

crypt: return unexpected EOF instead of Failed to authenticate decrypted block

Streams which truncated early with an EOF message would return a
“Failed to authenticate decrypted block” error. While technically
correct, this isn’t a helpful error message as it masks the underlying
problem. This changes it to return “unexpected EOF” instead.

The rest of rclone knows it should retry such errors.

Excellent. I am testing it now. I will let you know.

Is there anything specific on how I need to mount this for this test?

No, just look at the logs. You shouldn’t need -v.