Rclone windows Google drive

Hello, I recently moved from linux to windows for simplicity. I learned on the forum that I could speed up Windows Explorer which was very slow by default. I would like to know if what I did is optimal or if I can do even more to have an almost perfect reactivity under windows with rclone and google drive. Here is the .bat that starts rclone at windows startup Thanks

@echo off
C:\rclone\rclone mount Gcrypt: x: --bwlimit 20M:off --network-mode --cache-dir=C:\rclone\cache\Gcrypt --vfs-cache-mode full --user-agent="ams"
timeout /t 20
rclone rc vfs/refresh recursive=true

Forgot the project, I switched to linux. The support is too strong here.

hi, did not see your message till now.

that command looks ok. is there something that needs to be tweaked?

Hi Jonathan,

I think this all-round mount command for Google Drive on Windows will perform significantly better:

rclone mount --network-mode --buffer-size=0 --vfs-cache-mode=full --vfs-cache-max-age=720h --vfs-cache-max-size=10G --drive-pacer-min-sleep=10ms --drive-pacer-burst=200 --cache-dir=C:\rclone\cache\Gcrypt Gcrypt: x:

I don't know your free disk space and therefore set the max cache size to 10GB. The more disk space you can allocate to the cache the better. I don't see a need for rclone rc vfs/refresh recursive=true with this setup and therefore suggest you try disabling that.

The mount command is tuned to give good responsiveness in Windows Explorer. You may get even better performance by using the latest beta. It contains a fix to optimize the cooperation with Windows Defender.

The suggestion is based on this post, where you can find links to more info:

Please let us know how it performs, perhaps we can optimize to your specific usage/data/machine - or learn/improve from your experiences.

1 Like

I had such a problem with plex under windows in connection with rclone that I restarted linux, probably a tv series was involved, but plex itself sometimes closed on its own or stopped responding without too know why. Maybe the beta version of rclone would have solved the problem too, but that will be for next time..

I try: rclone mount Gcrypt: /mnt/unionfs --bwlimit=20M:off --allow-other --allow-non-empty --cache-dir=/mnt/Cache/vfs/unionfs --vfs-cache-mode full --vfs-cache-max-size 200G --vfs-cache-max-age 750h --tpslimit=7 --stats=0 --drive-pacer-min-sleep=10ms --drive-pacer-burst=200 --network-mode --buffer-size=0 --vfs-cache-poll-interval 10m --user-agent="ams" -v

I don't know if --network-mode is useless on linux.

Yes it is -> rclone mount

Those are windows flags.

Why that? You have your pacer stuff tuned up but that gimps these settings

I don't know some have different settings that's why I was asking the question. I often see --tpslimit in docker mounts etc too. So I would use rclone mount Gcrypt: /mnt/unionfs --bwlimit=20M:off --allow-other --allow-non-empty --cache-dir=/mnt/Cache/vfs/unionfs --vfs-cache -mode full --vfs-cache-max-size 200G --vfs-cache-max-age 750h --buffer-size=0 --vfs-cache-poll-interval 10m --user-agent ="ams" -v

I use a pretty simple method as I tend to start with defaults and only change if I have a reason to change them.

My settings when I used drive are here:

I tried to give a reason as to why I changed it along the way for each line.

I don't use rclone in a docker as it's overkill for me and adds no value. I don't run Windows as I run solely on Linux as it's a better experience for Plex.

My overall goals are 'hands free' and as simple as possible. More pieces in the mix, more things break.

1 Like

So what exactly does your mount look like? I have already tried to put the different values vertically, but it never works, I don't know why.

My mount looks exactly like the link I shared above :slight_smile:

I guess you are looking for this:

So it's just a story of \ after each line :slight_smile:
Here's what I put, I'm not sure what it's for:
--log-file /opt/rclone/logs/rclone.log
--log-level NOTICE
--rc-addr :5572
--drive-pacer-min-sleep 10ms
--drive-pacer-burst 200
--bwlimit-file 32M

Description=Remote Daemon
After=syslog.target network.target

ExecStart=/usr/bin/rclone mount Gcrypt: /mnt/unionfs
--dir-cache-time 5000h
--poll-interval 10s
--umask 002
--vfs-cache-mode full
--vfs-cache-max-size 200G
--vfs-cache-max-age 750h
--vfs-cache-poll-interval 5m
--bwlimit-file 32M



Those are setting the log file location and the level of the log file.

      --log-file string                      Log everything to this file
      --log-format string                    Comma separated list of log format options (default "date,time")
      --log-level string                     Log level DEBUG|INFO|NOTICE|ERROR (default "NOTICE")

I run a local server only I use so I use remote control to interact with rclone. This allows me to run things like a priming of the directory / file cache with a post command. It's not needed but something I do and allows me to change logging levels while rclone is running should I ever want to. Not requrired.

This is specific for Google Drive as Google had updated their API quota (not upload / download limits) so this allows rclone to use more API as you get 1 billion hits per day.

This means that each file upload or download can only use 32MB/s of bandwidth.

1 Like

Thanks for the explanation, it's much appreciated!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.