Mounting Cache Size

So I am using this cmd here to map my google drive. It works like a charm

rclone mount --vfs-case-insensitive --vfs-cache-mode full --write-back-cache --vfs-write-back 10s --vfs-cache-max-age 300s --vfs-cache-max-size 5000M --vfs-cache-poll-interval 60s --cache-dir c:\temps crypt: T:

I was wondering if I changed the 5000M cache max size to something larger will that cause any issue? I have a 500gb empty SSD just laying around the house that I can use for cache. Same thing with the --vfs-cache-max-age 300s , can I make that to a larger number without causing issues? This is a cmd I found on reddit , its been working for me. Im to all of the mounting part of rclone.

hello and welcome to the forum,

without knowing what you are using the mount for, hard to give specific advice.

only if you run out of free space

yes, in fact 300s is a very small value, as the default is 1h0m0s
so that means, once the file is downloaded into the vfs file cache.
after 300 seconds, rclone will remove that file from the cache.
note: rclone will never remove a cached file that is open/in-use by some app on your machine.

Thanks for your reply. Its for streaming. I use it for my Plex and Emby servers. Is there a max number that rlcone allows me to set for the cache max age and size?

as for the rclone cache, many rcloners so not use it.
when at home, with 1Gbps internet, i do not need the cache.

as my emby server is hosted in the cloud, i run rclone mount on that.

really, it just depends on the amount of space, if any, you want to give rclone.
and how long you want stale files to stay in the cache.
choose the values that work for you.

and might take a read of this topic and compare your command to that.

Do you know if the cache folder gets populated when a file is scan? I know its get populated when the file is played but not for sure if its scan. I use to use google drive software and when files are scanned in Plex or Emby the files are cached in a folder.

I have a 1gb internet as well but sometimes the video just doest play right away unless its cached. I get a 5-7 second start time on new files that not cached, If you dont mind can you share your rclone syntax for mounting?

not sure what problem you are trying to solve?
before you wrote 'It works like a charm'

yes, as scan and stream both read the contents of the file

hard to answer, maybe transcoding using too much cpu/memory
try playing a low-res video direct from t:\, not using plex.

1 Like

Hi Joshua,

These are the settings I would use for a good all-round mount of Google Drive on Windows with 400 GB available for caching in D:\temps:

rclone mount --network-mode --buffer-size=0 --vfs-cache-mode=full --vfs-cache-max-age=720h --vfs-cache-max-size=400G --drive-pacer-min-sleep=10ms --drive-pacer-burst=200 --cache-dir D:\temps crypt: T:

I think it will be good for Plex and Emby too, so I suggest you try it and let me know how it compares to your current command. Note: It may be a little slower initially when loading your most used files into the cache.

Here is a variant using only 5 GB caching in C:\temps in case you want to try it before adding the extra SSD disk:

rclone mount --network-mode --buffer-size=0 --vfs-cache-mode=full --vfs-cache-max-age=720h --vfs-cache-max-size=5G --drive-pacer-min-sleep=10ms --drive-pacer-burst=200 --cache-dir C:\temps crypt: T:

The suggestion is based on this post:

You can find descriptions of the used parameters here:

1 Like

@Ole @asdffdsa Thank you for all your help. I am going to try some things you guys suggested.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.