Rclone webdav timeout to check file upload

What is the problem you are having with rclone?

When sending a big file to ocis via rclone webdav, rclone show an error after the first attempt :

ERROR : Attempt 1/3 failed with 1 errors and: object not found

ocis is configured for using s3 backend storage.
When showing this error, the file is visible to the web interface but not yet available. If I cancel the second attempt, I just have to wait a bit more for the file to be available and visible, in the webpage and using rclone.

I think this problem could be solved using a bigger timeout for checking upload, but the flags that mention timeout don't change anything to my issue. I can (re)try the one you want if necessary.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.15.0-94-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

ocis using webdav (old implementation). I know there is a new one, but the new one expects the space id, I don't know how to get this id. I asked on reddit/owncloud but no response.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy film.mkv ocis:Test/ --progress

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[ocis]
type = webdav
url = https://ocis.p8a.eu/remote.php/webdav
vendor = owncloud
user = XXX
pass = XXX
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag


root@serveur:~# rclone copy film.mkv ocis:Test/ --progress -vv
2024/02/11 10:22:30 DEBUG : rclone: Version "v1.65.2" starting with parameters ["rclone" "copy" "film.mkv" "ocis:Test/" "--progress" "-vv"]
2024/02/11 10:22:30 DEBUG : Creating backend with remote "film.mkv"
2024/02/11 10:22:30 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2024/02/11 10:22:30 DEBUG : fs cache: adding new entry for parent of "film.mkv", "/root"
2024/02/11 10:22:30 DEBUG : Creating backend with remote "ocis:Test/"
2024/02/11 10:22:30 DEBUG : found headers:
2024/02/11 10:22:30 DEBUG : fs cache: renaming cache item "ocis:Test/" to be canonical "ocis:Test"
2024/02/11 10:22:31 DEBUG : film.mkv: Need to transfer - File not found at Destination
2024/02/11 10:22:31 DEBUG : film.mkv: Update will use the normal upload strategy (no chunks)
2024/02/11 10:25:08 ERROR : film.mkv: Failed to copy: object not found
2024/02/11 10:25:08 ERROR : Attempt 1/3 failed with 1 errors and: object not found
2024/02/11 10:25:08 DEBUG : film.mkv: Need to transfer - File not found at Destination
2024/02/11 10:25:08 DEBUG : film.mkv: Update will use the normal upload strategy (no chunks)
Transferred:        2.314 GiB / 4.496 GiB, 51%, 3.950 MiB/s, ETA 9m25s
Transferred:            0 / 1, 0%
Elapsed time:      2m48.0s
Transferring:
 *                                      film.mkv:  2% /2.248Gi, 6.598Mi/s, 5m38s^C

Maybe increase the timeout to something greater?

      --timeout Duration                   IO idle timeout (default 5m0s)

Default is 5 minutes.

I tryed once more. It has no impact. The upload doesn't even need more than 5 minutes.

I think the point is to wait more for the final check at destination. But there is no option I see.
Any other option?
Any dev possible to try my proposition?

When I retry later, the copy doesn't start, because rclone see that the file is already there and doesn't need to be transfered again.

Hello, any news on this? Should I post a bug request?