Rclone Web UI, hosted version

What is the problem you are having with rclone?

I wanted to use the hosted version of the Web GUI for my Rclone headless machine

GitHub - rclone/rclone-webui-react: A full fledged UI for the rclone cloud sync tool

-I will add that I can run Web Gui on my server.
-I will be grateful for any reply

after entering the username, ip and password unfortunately I get the error:

Error connecting. Please check username password and verify if rclone is working at the specified IP.

Run the command 'rclone version' and share the full output of the command.

rclone v1.60.0-beta.6409.6b158f33a

  • os/version: debian 11.4 (64 bit)
  • os/kernel: 5.10.0-16-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rcd --rc-user=abc --rc-pass=abcd --rc-allow-origin="https://rclone.github.io"

12:46:46 NOTICE: Serving remote control on http://localhost:5572/

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

That just starts the remote control portion.

To run the webgui, you need to pass the options over to start it.

rclone rcd --rc-web-gui

GUI (rclone.org)

Thank you for your response. I'm not sure we understand each other. My goal is to use the web gui available at this address:

Rclone WebUI

I don't want to run / use web gui on my server only remotely

it looks like this option doesn't work properly


Sorry as I'm not following as you seem to contradict your goal as in the OP, you stated.

Then you said:

So what is your goal? Are you trying to run the WebGUI? The remote control daemon? Are you trying to share that via the internet or only contain it locally?

If you remove the parameters and just state what the goal is, I can help out with the right flags/parameters.

Ah, I see as I didn't even realize that was an option.

You'd have to make your remote control daemon available on the internet.

That only runs it locally by default and nothing but your local machine can connect to that.

You need to adjust this:

--rc-addr - useful if you are running rclone on a headless machine, specify the private/public IP of your VM for rclone to bind to. (Optional)

That's either your or whatever IP you want to bind it to and you need to ensure the port is open/available via your router/internet and forwarded properly.

I was thinking about the Web GUI that the author provides at

Rclone WebUI

I can help out with the right flags/parameters.

Okay, give flags/parameters.

I have a vps server A at ip. and a vps server B at ip.
Rclone is installed on every server.On servers I have port 5572 open

On server A, I turn on the Web GUI:

rclone rcd --rc-web-gui --rc-addr :5572 --rc-user admin --rc-pass pass

now web gui is available at

the address is reachable from the internet.

I want allow Rclone on server B ip.2.2..2.2
so that he can be served by the web gui
at the address

what options / parameters should i use for sever ?

You can't.

They are unique instances so you'd run the webgui both on and if you aren't using the hosted one.

what do you mean ?

You started with using the hosted one:

and went away from it.

Yes, that's right. Because this code

I added to server B gave me nothing. I got an error ( Error at the top of this post ) when trying to login to hosted. So what code should I give to server B so that I can log in to the hosted and using web gui as if it were on server B

I answered that already:

That runs local only so you can't connect to it remotely.

You'd have to test it out as you'd have to allow the origin from the B to A.


Set the allowed Access-Control-Allow-Origin for rc requests.

Can be used with --rc-web-gui if the rclone is running on different IP than the web-gui.

it is clearly written that it can be separated.So I don't understand why you think that

You can see later, I answered you and you are quoting an old thing...


I try not to edit my posts so please just respond to the latest. Thanks!

I did this at the very beginning for the hosted version

rclone rcd --rc-user=abc --rc-pass=abcd --rc-allow-origin="https://rclone.github.io"

did not work.

For my server B

rclone rcd --rc-user=abc --rc-pass=abcd --rc-allow-origin="https://mydomain_server A"

did not work.

We covered that. You needed to bind the address so it's internet accessible.

That only allows the local machine to talk. You need to run that with

rclone rcd --rc-user=abc --rc-pass=abcd --rc-allow-origin="https://rclone.github.io" --rc-addr :5572

and forward that IP so it's internet accessible.

That means this part:

Head over to https://rclone.github.io/rclone-webui-react/. To login, enter the IP address, username and password of rclone rc server.

So you'd enter in URL here:

That's for using the hosted version of the rclone GUI.

I added and got

root@serv:~# rclone rcd --rc-user=abc --rc-pass=abcd --rc-allow-origin="https://rclone.github.io" --rc-addr :5572
2022/08/09 22:15:09 NOTICE: Serving remote control on http://[::]:5572/

in the login fields I can enter the ip of my server
and so is the same error


For a desktop computer/localhost, it works.

rclone rcd --rc-user=abc --rc-pass=abcd --rc-allow-origin="https://rclone.github.io"

in the login fields IP / URL


For a headless machine = I don't know .If anyone knows please reply
Thanks to Animosity022 for the tips

The problem lies with the self hosted version as that hosted version never makes a connection to the machine.

I didn't know it existed as a thing so not sure if it ever worked / just broke or whatnot.

--rc-allow-origin works just fine as that's not the issue.

Short term, either run the GUI yourself or not.

I tested running from a different machine and no issues locally.

I did something broad:

^Cfelix@gemini:~$ rclone rcd --rc-user=abc --rc-pass=abcd --rc-allow-origin=* --rc-addr :5572
2022/08/10 12:40:07 NOTICE: Serving remote control on
2022/08/10 12:44:50 NOTICE: Warning: Allow origin set to *. This can cause serious security problems.


Local on my Mac connecting to a Linux machine: