Rclone+VMWare ESXI

Hi all,
I’m using rclone for backuping all my Debian/Ubuntu VMs on cloud storage.
I’d like to use on ESXI for backuping all my VMs on cloud storage.
Could you ever try this?
Could you think in a next version, this feature can be impemented?
Indeed, I get an issue about argument fault, when i try to run rclone on ESXI…

Thanks.

1 Like

You are running rclone directly on ESXi is that right? Is ESXi a linux environment?

Can you paste the error message (or a screenshot) please?

Hi,
Thanks for reply me.

find a screenshot with my ESXi:

Thanks.

Same issue here. Glad to hear if there will be a solution. But ESXi is not regular linux.

Here is the output of uname

VMkernel PK-ESX 6.0.0 #1 SMP Release build-2494585 Feb 5 2015 19:07:22 x86_64 x86_64 x86_64 ESXi

@prc2k10 yes, you’re right, I forgot to screenshot the output of uname :slight_smile:

@ncw if you have a solution, It will be fantastic :smiley:

Thanks

Can you try this binary

https://pub.rclone.org/rclone-v1.36-260-gdf11d1d5-amg64-go-tip.zip

Which is latest rclone beta compiled with go tip.

If that doesn’t work, can you please make a new issue on github so we can track the progress.

no success on this. so we will have to investigate, i am going to make a new issue on github.

Hello,
Same issue.
Have you some news?

I’ve tested with rclone v1.37…always same issue :frowning:

Did you make the issue? I can’t find it?

I am also running an ESXI 6.0 host with windows vms amd would love an easier way to backup my vms- which include terabytes of movies, and family data. My esxi host made me shutdown my plex server cause I was running out of memory? no way?! I have so much unused space.

I hope there will he a solution to this soon.

Good luck,

Kevan

I need someone to please make a new issue on github and work with me to get it fixed.

Done, I made an issue.
The error message is provided by the OS VMWare ESXI.
I searched on google about the error message "segmentation fault", it seems to be a problem with memory.
How many memory uses rclone?

Thanks. That issue is

If anyone wants to help debug this I'll post updates on that issue

Hello,
Maybe could you take a look with this page/url
https://my.vmware.com/web/vmware/details?downloadGroup=ESXI60U2_OSS&productId=491
It can help developpers to create 3rd party app for Vmware ESXI.

thanks

Hello,
How are you?
Do you have any update aboute the issue with ESXI?

Thanks.

Please subscribe to the issue for updates

Hello,
I'd found some interesting article about Vmware and how to install 3rd party binaries.
It's not easy, but it's fully fonction with rsync

http://www.zemris.fer.hr/~sgros/sysadm/esxi_hacks.shtml

http://www.magikmon.com/mksbackup/ghettovcb.en.html

The go binaries I've tried in the ESXi shell have been statically linked but haven't worked.

I reported this on the go issue tracker here. There is speculation there that the linux version doesn' t support the syscalls that go uses

Hello,
How are you?
I back to you with some news about that problem.
Maybe could you check if it can be solved with that thing. in this link, someone wanted to install Rsync binary which is not included with ESXI.
THan he explained how he did it for working with ESXI.
Maybe we need to follow the same method with RCLONE.
What do you think about it?