Rclone VFS and MergerFS Setup on Ultraseedbox

I'm a Linux newbie as of about 5 months ago and had been running Cloudbox for my PMS on a VPS. I've moved to Ultraseedbox(USB) and no longer have root, so Cloudbox is out. That's okay as I like the challenge of learning to put this together. But I'm pretty stumped at this point. I've followed USB's guide(link) all the way through until is says to "Enable and start the two systemd services by using:
systemctl --user enable --now rclone-vfs && systemctl --user enable --now mergerfs

I get this error: Job for rclone-vfs.service failed because the control process exited with error code.
See "systemctl --user status rclone-vfs.service" and "journalctl --user -xe" for

I've searched and searched this forum, Google, etc. and tried for 4+ hours to figure out what is causing this. My rclone-vfs.service file is modeled after @Animosity022's but I left in the things USB had already included in theirs. I'll post it in the next reply.

rclone version:
rclone v1.50.2

  • os/arch: linux/amd64
  • go version: go1.13.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Debian 4.19.67-2+deb10u2~bpo9+1

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

systemctl --user enable --now rclone-vfs && systemctl --user enable --now mergerfs
Description=RClone VFS Service


ExecStart=/home16/fivepack/bin/rclone mount gmedia: /home16/fivepack/Stuff/Mount \
  --allow-other \
  --buffer-size 512M \
  --config /home16/fivepack/.config/rclone/rclone.conf \
  --use-mmap \
  --dir-cache-time 168h \
  --log-level INFO \
  --log-file /home16/fivepack/scripts/rclone.log \
  --timeout 1h \
  --umask 002 \
  --poll-interval=15s \
  --vfs-cache-mode writes \
  --vfs-read-chunk-size 64M \
  --vfs-read-chunk-size-limit 1G \
  --tpslimit 10 \
  --tpslimit-burst 10
ExecStop=/bin/fusermount -uz /home16/fivepack/Stuff/Mount

Can you please post the log file from: /home16/fivepack/scripts/rclone.log

The log file looks like most of it is instructions/guide. At the very end it says this:

Command mount needs 2 arguments maximum: you provided 3 non flag arguments: ["gmedia:" "/home16/fivepack/Stuff/Mount" "\"]


  1. update to the latest stable version of rclone v1.51.0
  2. change to this --log-level DEBUG
  3. test again
  4. post the entire log.

The error would indicate that you have an issue with the service file. A trailing space or something as I don't see anything obviously wrong.

You can troubleshoot by using it outside of systemd and just copying the command out.

As a FYI, you have 512M buffer per file so that's going to consume a lot of memory per file. What's the specs on your seedbox?

You do not need a debug log either as the process isn't starting so changing that won't do anything.

that is a good suggestion.
perhaps start with the most basic command and add flags one at a time

rclone mount gmedia: /home16/fivepack/Stuff/Mount

I ran just the mount command and my Putty froze. So I closed and opened the session again and reran it. This is the result:

2020/04/26 19:17:07 Fatal error: Directory is not empty: /home16/fivepack/Stuff/Mount If you want to mount it anyway use: --allow-non-empty option

And when I view that folder, it appears to be mounted as it has the contents of my Gdrive.

i am not a linux expert, but i am learing.
perhaps there is another rclone mount already running in the background.
i ran into that problem many times so perhaps you can learn from my mistakes...

to see if rclone mount is running.
mount | grep rclone

and you can kill it by
fusermount -uz /home16/fivepack/Stuff/Mount

Is that folder empty? It needs to be unless you really want to overmount on it (not recommended).

Thanks I'm still learning a lot too. That worked, it was running. I killed it with your command. So the mount command is working. What should I try next? I know you said add flags one at a time but not sure how to do that.

well, what command did you run to get the mount working?

i would create a .sh bash file with
rclone mount gmedia: /home16/fivepack/Stuff/Mount

if that works, then kill the mount and keep adding a couple of flags at at time and repeat

That's the command that got it working. Unfortuantely, you are talking beyond my level of Linux right now. :slight_smile: I don't know how to create a .sh bash file(or why I would do so to troubleshoot my .service file). I should have been more specific, how do I "add more flags" to see which one is breaking my .service file? Thanks!

Its interpretting that last '\' as an argument when it isn't. That is escaping the 'new line'. Is there a space in your file after that '\' on this line?

ExecStart=/home16/fivepack/bin/rclone mount gmedia: /home16/fivepack/Stuff/Mount \

For simplicity, try this instead.

ExecStart=/home16/fivepack/bin/rclone mount gmedia: /home16/fivepack/Stuff/Mount --allow-other --buffer-size 512M --config /home16/fivepack/.config/rclone/rclone.conf --use-mmap --dir-cache-time 168h --log-level INFO --log-file /home16/fivepack/scripts/rclone.log --timeout 1h --umask 002 --poll-interval=15s --vfs-cache-mode writes --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 1G --tpslimit 10 --tpslimit-burst 10

and then post the complete logfile if it doesn't work.

perhaps change --log-level INFO to --log-level DEBUG

No need to post the logfile I don't believe. Here's what I got when I tried that:

mount: unrecognized option '--allow-other'
mount: only root can do that

If you're not running as root remove it. That's better though.

I removed it and reran this below, worked this time! What I don't understand, why would the seedbox show that in their example in their guide? They know they don't allow root. Just odd to me. Now, what will not having -allow other in there affect/change?

If you run as root allow-other just let's other users access the mount point. So if your running as yourself and accessing it as yourself then no impact.

If you have multiple users and you need to access to from them then you'd have to add

Allow non-root users to specify the allow_other or allow_root mount options (see below).

To /etc/fuse.conf

Then you can use that flag from a non-root user.