RClone Unions: Is there a way to set a specific remote to read-only?

What is the problem you are having with rclone?

I have a number of remotes in a union and I'd like to set some to "read-only" so no new files get placed in them.

Ideally it would be something like a read_only = true attribute for the remote.

I searched for something similar in the documentation and in the forum and could not find it, not sure whether it doesn't exist or it's just my search-fu being weak today.

Run the command 'rclone version' and share the full output of the command.

rclone 1.58.1-termux

  • os/version: unknown
  • os/kernel: 4.14.190-lineageos-g4280f541b3f6 (aarch64)
  • os/type: android
  • os/arch: arm64
  • go/version: go1.18.1
  • go/linking: dynamic
  • go/tags: noselfupdate

yes, latest version.

Which cloud storage system are you using? (eg Google Drive)

The remote I read/write to is a RClone union of many upstream remotes, all of them individual accounts in a myriad of providers.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy local_dir union_remote:remote_dir

The rclone config contents with secrets removed.

type = union
upstreams = rem01: rem02: rem03: ...
create_policy = mfs

A log from the command with the -vv flag

{not applicable}

If you take a look at Union you'll see an example in the first few lines of the documentation.


Attribute :ro and :nc can be attach to the end of path to tag the remote as read only or no create, e.g. remote:directory/subdirectory:ro or remote:directory/subdirectory:nc.

So it was really just a case of weak search-fu on my part :slight_smile: :wink:

thanks for the clue-bat, I needed (and deserved) it :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.