Rclone Union mfs (most free space) not working for FTP

What is the problem you are having with rclone?

I'm having some trouble getting rclone union working correctly. The union itself works well since all the remotes are combined. Reading and listing files works perfectly.

Currently I have 3 remotes in the union. All of them use plain FTP. Two of the remote's are 7.6TB's big and have around 4,5TB's of space left. One of them is 3TB's big and has around 2.4 TB's of space left.

The problem is that all of the writes seem to be going to the 3TB remote. This is rather strange since for "create" I use the mfs (most free space) policy.

While checking the output from rclone I saw the following for all of the remote's:

NOTICE: Free Space is not supported for upstream ftp_volume2, treating as infinite

Is there a way to make the mfs policy work as it should with FTP remotes?

Which remote's support the mfs policy? I can't see this documented (or I looked over it).
I'm using a Synology NAS, which remote type would be a well performing solution?

What is your rclone version (output from rclone version)

rclone v1.53.2

  • os/arch: linux/amd64
  • go version: go1.15.3

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 20.04, Desktop

Which cloud storage system are you using? (eg Google Drive)

FTP and Union. The FTP server is a Synology NAS (DS414).

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone mount \
 --config=/root/.config/rclone/rclone.conf \
 --vfs-cache-mode full \
 --vfs-cache-max-age 6h \
 --vfs-cache-max-size 150G \
 --vfs-case-insensitive=true \
 --async-read=false \
 --allow-other \
 --umask=0 \
 --file-perms 0777 \
 --vfs-read-ahead 5G \
 --fast-list \
 --buffer-size 2G \
 --cache-info-age=60m \
 --dir-cache-time=60m \
 cifs_union: /mnt/cifs_union

While the folder name says cifs_union, it is actually a FTP union. CIFS didn't have very good performance, but the mfs policy did work.

The rclone config contents with secrets removed.

Pastebin link to my rclone config:

Thanks in advance! :slight_smile:

A FTP site doesn't support showing you space so rclone can't report free space.

Check out:

Thanks I didn't know about that!

For future reference:

You can use "rclone about " to find out the free space left on a remote. I switched from FTP to SFTP and it works now, after some debugging. For SFTP rclone apparently uses the df -k command to get the free space.

If using a Synology NAS, SSH should be enabled for this to work. The shares should also be renamed to the name of the storage pool.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.