Rclone treating --links like --copy-links

What is the problem you are having with rclone?

I'm on a Mac using rclone sync --links. In two directories there are aliases that point to a directory in another location. When rclone runs, the first alias fails to copy over and generates this error:

2022/07/28 15:36:03 ERROR : Active efforts/Conferences or presentations: Failed to copy: open /Users/jpollock/Scripts/rsync/vdrive/NCCRC/Active efforts/Conferences or presentations: permission denied

For the second alias, rclone follows the aliases and copies the aliases' target directories to the remote server, which it shouldn't be doing if I'm specifying --links. Then, if I run rclone --links again, I get this error:

2022/07/28 10:01:32 ERROR : Active efforts/Fundraising-related: Failed to copy: open /Users/jpollock/Scripts/rsync/vdrive/NCCRC/Active efforts/Fundraising-related: is a directory

The really weird thing is that I have a ton of aliases in the source folder, but it's only doing this with these two aliases; other aliases copy over properly. I tried deleting and re-creating the aliases, and the problem persists.

Just to anticipate the question: there is nothing else in the same directory as this alias that has the same name. A full ls -al of the directory shows no temp files or anything else that would explain this behavior.

I tried running with -vv, and the logfile doesn't actually show the target directory being copied over even though that happens, which I also can't explain. On my last run I deleted the mistakely-copied target directly from the destination server, then re-ran rclone, and the target directory was back on the destination server gain.

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.1

  • os/version: darwin 12.4 (64 bit)
  • os/kernel: 21.5.0 (x86_64)
  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.18.1
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Windows fileserver mounted as an AFP volume.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/local/bin/rclone" -vv sync /Users/jpollock/Documents/Job-related/PJC/RTC stuff/NCCRC/ /Users/jpollock/Scripts/rsync/vdrive/NCCRC/ --exclude MariaFolder/ -exclude AmandaFolder/ --links

The rclone config contents with secrets removed.

using the defaults; no config file

A log from the command with the -vv flag

I've pasted the only relevant entries avove.

Can you run with -vv and share the full log?

Sorry for the delay! I tried to paste the full log but it was too big for the forum's buffer, so I put it on Google Drive here: rsyncresults-2022-07-28-15:27 - Google Drive.

That seems to be just a permission thing.

id
ls -al  /Users/jpollock/Scripts/rsync/vdrive/NCCRC/Active efforts/Conferences

What does that show?

The "Conferences and Presentations" alias doesn't get copied over because of the "permission denied" error, so it doesn't exist in the destination directory (which is where you asked about). Here's what the permissions look like for the alias at the source:

% id
uid=501(jpollock) gid=20(staff) groups=20(staff),12(everyone),61(localaccounts),79(_appserverusr),80(admin),81(_appserveradm),98(_lpadmin),33(_appstore),100(_lpoperator),204(_developer),250(_analyticsusers),395(com.apple.access_ftp),398(com.apple.access_screensharing),399(com.apple.access_ssh),400(com.apple.access_remote_ae)
% ls -al Conferences\ or\ presentations
-rw-r--r--@ 1 jpollock wheel 1028 Jun 23 18:11 Conferences or presentations

So it has read the necessary read permissions.

Also, the second error is not permissions related:

2022/07/28 10:01:32 ERROR : Active efforts/Fundraising-related: Failed to copy: open /Users/jpollock/Scripts/rsync/vdrive/NCCRC/Active efforts/Fundraising-related: is a directory

That alias is the one where rclone first copies over the alias's target to the destination (which it shouldn't be doing) and then subsequently generates this "is a directory" error when it tries to copy the alias over the now-existing directory on the destination.

What does:

rclone lsd /Users/jpollock/Scripts/rsync/vdrive/NCCRC/Active efforts
rclone lsl '/Users/jpollock/Scripts/rsync/vdrive/NCCRC/Active efforts/Conferences or presentations`

show?