Rclone to OneDrive has problems with spaces in filename

I’m not sure if this is an rclone problem or a OneDrive oddity. I’m trying to ‘rclone copy’ a directory full of pictures to OneDrive, and rclone insists on recopying all files that have a space in the filename every time I ‘rclone copy’ the tree.

Other than renaming the 400-some files with spaces in them, is there a way to have this work the way it does for the other 38K files?


I also have this issue, it didn’t seem to be an issue a few weeks ago but now all files with a space in the name have the spaces replaced with a + which messes up the copy, basically it copies all files with spaces again because it doesn’t recognize test+file.tmp as the original file test file.tmp

Any help would be greatly appreciated.

I have confirmed that the latest BETA of rclone fixes this issues, you can download it here


@edimusxero Are you sure? I just tried the latest version (rclone v1.36-133-g0f07b63f) from beta.rclone.org and it is still trying to recopy all files that have a space in the filename.


yea, it definitely works. The issue may be that you need to re back everything up so that future backups are recognized. I had that issue too where things that had already been renamed with the + were not recognized but once I cleared my backups and re uploaded everything things were not renamed and future backups worked without a hitch.

Thanks for the tip (re-backing up). That was it! Confirmed that it’s fixed.