RClone to IDrive: File is made instead of the backup directory, delete the file and the directory appears in its place

I'm testing our iDrive e2 and am trying to use RClone to backup files on my NAS. So far, I've got as far as doing a test backup with a few random files in it

The command I'm using is:
rclone sync /Volumes/BF_Drive/test-backup/ e2:backup

The config file looks like this:

type = s3
provider = Other
access_key_id = XXXX
secret_access_key = XXXX
endpoint = backup1.w5d6.ie.idrivee2-37.com

and the log file says this:
2022/08/17 19:50:54 INFO : Screenshot 2022-08-16 at 09.48.06.png: Copied (new)
2022/08/17 19:50:54 INFO : path188.png: Copied (new)
2022/08/17 19:50:55 INFO : path36.png: Copied (new)
2022/08/17 19:50:55 INFO : Screenshot 2022-08-16 at 09.48.59.png: Copied (new)
2022/08/17 19:50:55 INFO : Screenshot 2022-08-16 at 12.15.49.png: Copied (new)
2022/08/17 19:50:55 INFO :
Transferred: 484.645 KiB / 484.645 KiB, 100%, 0 B/s, ETA -
Transferred: 5 / 5, 100%
Elapsed time: 1.0s

The behaviour I'm seeing is very strange. If I run the sync command and then look in the iDrive web interface I can see one file in the bucket that has the name of the directory. If I open it, I just get the info page for that file. If I then delete the file through the IDrive web interface, it is replaced by a directory of the same name. If I open that, all my files are there.

It's as if rclone is uploading an empty file with the same name as the directory. The IDrive interface shows the file but not the directory - presumably because they have the same name -. Deleting the file then allows the directory to be shown.

Am I doing something wrong or is there a problem with IDrive and rclone?

I figured it out. The endpoint that it shows in IDrive is not quite what rclone needs. I deleted the name of the bucket from the beginning of the endpoint and included it in the command like this:
rclone sync /Volumes/BF_Drive/test-backup/ e2:backup1

Now it works as expected.

hello and welcome to the forum,

need to delete/redact the access_key_id and secret_access_key
that info should never be posted.

Of course, thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.