Rclone sync fails when destination doesn't support sparse files

What is the problem you are having with rclone?

When running a sync operation rclone just infinitely copies files, constantly overwriting already downloaded ones. Destination file system is exFAT so I have to use --local-no-sparse

Run the command 'rclone version' and share the full output of the command.

PS C:\Users\user> rclone version
rclone v1.57.0
- os/version: Microsoft Windows 10 Enterprise LTSC 2021 2009 (64 bit)
- os/kernel: 10.0.19044.1706 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.17.2
- go/linking: dynamic
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync --progress --local-no-sparse gcrypt:Music/Library I:/Library

The rclone config contents with secrets removed.

[gdrive]
type = drive
client_id = xxx.apps.googleusercontent.com
client_secret = xxx
scope = drive
token = {"access_token":"xxx","token_type":"Bearer","refresh_token":"xxx","expiry":"2022-06-13T12:34:47.1458457+02:00"}

[gcrypt]
type = crypt
remote = gdrive:/vault
filename_encryption = standard
directory_name_encryption = true
password = xxx

A log from the command with the -vv flag

Sorry no log as I would have to re-download over 368 GB which takes ages on my connection but I have screenshots of the issue.

It would help me track this down if you could tell me what the ERROR message is you get when trying to dowload to extfat.

What you see on the screenshot is all there is apart from a couple more dial tcp: lookup www.googleapis.com: no such host messages because my internet drops out for a few seconds sometimes.

I see...

Can you do a test for me?

Copy a smallish file (> 10MB) to your extfat partition

rclone -vv copy gcrypt:Music/Library/path/to/small/file.bin --multi-thread-cutoff 10M I:/Library --retries 1

Then do

rclone lsl gcrypt:Music/Library/path/to/small/file.bin 
rclone lsl I:/Library/file.bin
rclone md5sum --download gcrypt:Music/Library/path/to/small/file.bin 
rclone md5sum I:/Library/file.bin

And post the output of all the rclone commands? You'll need to adjust the paths as appropriate. Don't use the --local-no-sparse flag.

Thank you