Rclone sync doesn't transfer files

I'm having a problem with sync/copy command:

I can upload to my drive without any problem, but if I try to make a copy or sync, it stuck at "trasnferring" mode:

Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA -
Errors: 0
Checks: 52955 / 52955, 100%
Transferred: 0 / 2, 0%
Elapsed time: 58.7s

  • 0pleg6js8t4i6hldae9j1t.h0gn94gic7fp64gvp6vfc4: transferring
  • kr9t7oppphqa9eqp24jtje.1adu6ueq23jnll8s6ssve0: transferring

OTH, if I do the SAME command at my computer, it works fine:

Transferred: 4.684G / 34.510 GBytes, 14%, 16.426 MBytes/s, ETA 30m59s45s
Errors: 0 / 52955, 100%
Checks: 52955 / 52955, 100%
Transferred: 0 / 2, 0%
Elapsed time: 4m52s

  • 0pleg6js8t4i6hldae9j.gn94gic7fp64gvp6vfc4: 24% /9.848G, 10.312M/s,
  • kr9t7oppphqa9eqp24jt.du6ueq23jnll8s6ssve0: 9% /24.662G, 10.043M/s,

Both cases are the same config file, the same rclone version.

Run the same command with -vv and share the debug log.

The "transferring" here may mean that it's verifying checksums and stuff to ensure it's been copied/moved properly. Assuming this is Google Drive, I believe it supports server-side copy/move, which would explain the reason you're seeing no transfer time.

When you upload from your computer, it's actually uploading because the file doesn't already exist, right? Hence you'll see actual transfer times and whatnot.

At least, this is my guess based on the information you've provided so far. As @Animosity022 said, you should provide verbose logs. In addition, can you clarify where the first attempt is being run (it's clearly not being run on your computer given "OT[O]H, if I do the SAME command at my computer, it works fine", but I don't know where it is being run)?

There are the lines that shows this file (all others are checking all the other files)

2019-05-17 22:03:56 DEBUG : kr9t7oppphqa9eqp24jtjevjuo/nf2pupt24n031oj5f448fp2giq0gqluiilc98ovjaadg7oci3g61fkgv3e0at7g5uv6kbe0c9ct8fvkcn92qb3ea7vs1d44j0tm7hks2cler6ao81pmlke86bcck6durq4q21adu6ueq23jnll8s6ssve0: Received error: googleapi: Error 403: User rate limit exceeded., userRateLimitExceeded - low level retry 7/10

You can see too, that it shows, o of 0 bytes transfered, like if it can't get the filesize right.

The really stranger is that this happens with ALL the files on the server, but if I try to upload new files to the Drive, it works perfect. And if I run the same command of copy/sync on my computer, it works fine.

You still aren't sharing the command nor the log so it's super hard to guess.

403s are from:

  • Hitting a quota for the day (750GB for normal uploads and 100GB server side)
  • doing something too fast

I'm guessing you are doing a server side command perhaps which is giving you the 403 and not a server side, which works.

With no command/logs, just a guess.

1 Like

Sorry, I forgot the command:

rclone sync "googleD1:Media" "googleD2:Media" --transfers 6 --checkers 10 -v -P --drive-chunk-size 16M --fast-list --user-agent="Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36"

It isn't serverside.

Are you using 1.47?

Yes I am,

rclone version
rclone v1.47.0

  • os/arch: linux/amd64
  • go version: go1.12.4

I use the same command at my computer, and it works fine (same config file and same rclone version).

1.47 introduced server side between remotes so you are hitting the 100GB quota.

Use --disable copy

and it will go back to using your own bandwidth and the 750GB per day limit.

1 Like

Thanks for the fix :smiley: Now works :smiley:

I don't know why on my computer, 1.47 doesn't do the server side by default, maybe a windows bug?

PS: From some time ago, the serverside copy is 750 too, so, 750 from serverside + 750 of "normal" copy. :slight_smile:

Last I tested, it was only 100GB, basically, you can server side until you get a 403 and disable it.

When you hit a 403, you know you've done too much.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.