Rclone stuck during copy

During copy rclone stuck

Version v1.61.1 Same behavior at latest version 1.62.2

Which cloud storage system are you using? (eg Google Drive)

destination: Ceph File System

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -vv copy --no-traverse --update --skip-links /home/tmp/m2 /shared/maven

A log from the command with the -vv flag

Stacktrace rclone.stacktrace · GitHub

[2023-05-26T15:42:17.487Z] 2023/05/26 15:42:17 INFO  : 
[2023-05-26T15:42:17.487Z] Transferred:   	    1.177 MiB / 1.177 MiB, 100%, 3.866 KiB/s, ETA 0s
[2023-05-26T15:42:17.487Z] Checks:              1524 / 1525, 100%
[2023-05-26T15:42:17.487Z] Transferred:          367 / 367, 100%
[2023-05-26T15:42:17.487Z] Elapsed time:      56m0.0s
[2023-05-26T15:42:17.487Z] Checking:
[2023-05-26T15:42:17.487Z]  * org/apache/maven/maven…6/_remote.repositories: checking

what is the reason to use rclone here? You copy files between two local filesystems. Why adding extra complexity instead of cp or rsync

it’s mount mount over network

yes but mounted to local filesystem. it is effectively using rclone as local copy tool.

Have you tried simply copy all these files using your OS copy command?

You can also try different way of mounting Ceph FS - kernel driver vs. ceph-fuse. But definitely you do not need rclone for what you are doing - copy between two local folders (even if one is mounted other FS)

Is this file very big?

What rclone is doing according to the backtrace is checking the hash of the source and the destination match. That can take some time as it has to read the entire file to hash it.

If you don't want this then try --size-only or --update

About 1-2 gigabytes
Rclone show checking message endlessly but if i run command lsof -p $rclone_pid then rclone start working and successfully completed

Not huge then. It should only take rclone a few seconds to checksum this. Its more likely to be limited by the speed of the disk.

That is extremely odd! Is that repeatable?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.