Rclone simple {} comma separated list not working as expected

rclone move /mnt/storage/test gdrive:test --include *.{mkv,mp4}

In a test folder, with the structure:


Running the command gives me the following error (even with copy):

Command move needs 2 arguments maximum
Command copy needs 2 arguments maximum

It works if I do any of the following:

--include *.mkv --include *.mp4
--include *.mkv
mv src/*.{mkv,mp4} dest

According to the rclone documentation on filtering, this should work, as this is the example given:

--include *.{png,jpg}

Am I missing something, or is this a bug?

I think you just need to quote it.

felix@gemini:~$ rclone move /mnt/storage/test gdrive:test --include *.{mkv,mp4}
  rclone move source:path dest:path [flags]

      --create-empty-src-dirs   Create empty source dirs on destination after move
      --delete-empty-src-dirs   Delete empty source dirs after move
  -h, --help                    help for move

Use "rclone [command] --help" for more information about a command.
Use "rclone help flags" for to see the global flags.
Use "rclone help backends" for a list of supported services.
Command move needs 2 arguments maximum: you provided 3 non flag arguments: ["/mnt/storage/test" "gdrive:test" "*.mp4"]
felix@gemini:~$ rclone move /mnt/storage/test gdrive:test --include '*.{mkv,mp4}'
2019/11/02 17:35:20 Failed to create file system for "gdrive:test": didn't find section in config file

Thanks! That worked, I'm just stupid.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.