RCLONE Setup Unraid (Help)

I've been trying to setup Rclone on UnRaid and I cannot get it to work.

I installed Binhex's Rclone docker and I could setup a remote, but I think there is something wrong with the file system.
When I restart the docker, it loses the remote, so it does not seem to be writing to storage.

The config storage is the default "/home/nobody/.config/rclone/rclone.conf" I don't know if this needs to be changed or how.

Also, when I tried copying to my b2 bucket, it could locate the bucket, but could not locate the local folder I was trying to copy from on the NAS.

I would input this:
rclone copy “/mnt/user/TestShare/TestFolder/” B2Cloud:b2Bucket

This did not work, it would error saying it cannot find path /mnt/user/TestShare/TestFolder/

I've spent at least 6 hours trying to set it up and I've seemingly watched all the tutorials on YouTube and feel like I've looked at all the documentation, but I cant find the answer.

Any help would be really appreciated.
rclone version:

rclone v1.66.0

  • os/version: arch (64 bit)
  • os/kernel: 6.1.82-Unraid (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.22.1
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

B2 Cloud Storage

The command you were trying to run

rclone copy “/mnt/user/TestShare/TestFolder/” B2Cloud:b2Bucket

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

I tried changing the config location and it now spits out this.

NOTICE: Config file "/home/nobody/.config/rclone/rclone.conf" not found - using defaults
; empty config

A log from the command that you were trying to run with the -vv flag

I cannot find the logs.

It looks like a problem is with this docker setup. If you are not familiar with docker do not use it. Install stand-alone rclone binary.

the support forum for that is https://forums.unraid.net/topic/44108-support-binhex-general/

Ah OK thank you for your help. What would be the best way to install the binary? Does rClone have a native plug in?

Thank you, it looks like that it might be a while before they can fix it. I'll send something over there to see if they can help.

Not sure what you mean by plug-in. Go to rclone downloads page and download binary for your specific platform and architecture.

Rclone project provides working binaries. Any packaging like docker is really out of the core scope. It is left to specific solution communities.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.