Rclone serve [webdav] is allowing file creation to patterns in the exclude list

What is the problem you are having with rclone?

rclone serve [webdav] is allowing file creation to patterns in the exclude list

i am pairing this with mount_webdav on macos as an alternative to using Fuse. trying to prevent it creating ._* resource files when i drag/drop files to the mounted dropbox destination. the exclude list apply to reads, but not to writes. (the ._* files also show after first write, i assume via caching, but after remounting; the exclude lists block those files)

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.0
- os/version: darwin 12.5 (64 bit)
- os/kernel: 21.6.0 (arm64)
- os/type: darwin
- os/arch: arm64
- go/version: go1.18.3
- go/linking: dynamic
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

dropbox

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone serve webdav dropbox: --addr localhost:12436 --exclude-from /Users/user/.config/rclone/macos-meta-excludes

macos-meta-excludes:

.DS_Store
._*
**/._*

The rclone config contents with secrets removed.

[dropbox]
type = dropbox
token = {"access_token":"redacted","token_type":"bearer","expiry":"0001-01-01T00:00:00Z"}

A log from the command with the -vv flag

too long, and includes tons of metadata checks on personal files during the test/copy

Currently the filter flags only affect listing of files in the VFS.

This could be extended to stop creation of files / dirs if they were excluded - maybe that would be sensible.