Rclone serve webdav does not allow seeking in nextcloud

i have rclone serve webdav share:movies
localhost:8080 is added in rclone as external storage.
When i open movie mkv or mp4 in nextcloud, it starts playing fine, but when i want to seek it it goes to the begining.

No such problem in mount.
Why ?

I’m not sure I understand your setup.

Are you saying that you are using rclone as an external storage for nextcloud?

In rclone serve webdav share:movies where is share: stored?

All the rclone backends support seeking (well Range requests) and so does rclone serve webdav so I suspect this is a nexcloud -> external storage using webdav problem.

So using rclone as an external storage using rclone mount works OK - is that what you are saying?

yes, mount works fine.

share is google drive encrypted.
so when i add in nextcloud settings external storage [ /nxt ] , which is rclone mount share:movies /nxt
seeking works fine.
But if i add in nextcloud settings external storage which is webdav url localhost:8080 (rclone serve webdav share:movies) i can open movie but can not seek.

It is probably related to how nextcloud handles files, because when i open this localhost:8080 (served from rclone, not nextcloud) directly in mx player on android or nplayer on ios or vlc - works fine, i can seek mkv and mp4 files.

But this web based player in nextcloud can not seek movies when accessing webdav served files.
Mount is ok, webdav not.

It sounds from your description above that this is a bug in nextcloud rather than rclone.