RClone seems to ignores --modify-window on Linux for directories

What is the problem you are having with rclone?

Summary: rclone on Linux wants to re-copy or re-modify directories to Gdrive when using an exFat source drive despite setting of modify window


I have an external drive formatted with exFat with a directory of about 70,000 files. If I first synch the contents with a windows 7 NTFS drive (using other software), and then (from the NTFS drive) synch to GDrive (using RClone), it works fine. A couple dozen or so files are copied as expected.

If, on windows, I synch directly from the exFat drive to GDrive using RClone with the modify-window option set, then it also synchs correctly. Without the option it wants to modify 20000 timestamps.

But, on Linux, if I synch directly from the exFat drive to GDrive using RClone with the modify-window option, it seems to want to create 4000 directories in addition to the expected 33 files to be copied. I'm concerned about corrupting my GDrive target and unnecessary overhead in the process.

What is your rclone version (output from rclone version)

rclone v1.45
- os/arch: linux/amd64
- go version: go1.11.2

(On windows, it's 1.47)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Linux Xubuntu 18.04, 64 bits

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run

On Linux:

./rclone  --fast-list --transfers=40 --checkers=40 --tpslimit=10 --drive-chunk-size=1M --max-backlog 200000 --verbose --log-file=./rclone2.log -n --modify-window=5s  sync  /media/mark/DATA_ARK/D-crypt gd2:D-crypt

The rclone config contents with secrets removed.

type = drive
client_id = 2...
client_secret = ...
scope = drive
token = 


This log was made without -vv because the -vv file was 23mb and didn't show any additional information about directories (though it did show more information about files).

You got a really old version. You'd want to update that first and try again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.